Last song transferred takes FOREVER (using Media Monkey)

When transferring especially large playlists, Media Monkey happily moves along very quickly… until the last song.

The progress bar then stops moving and reads transferring “50 of 50” or “300 of 300” (or whatever.) In comparison with its previous speed, it stays “stuck” there for a VERY long time.

According to Media Monkey’s forum, the Fuze is having to “catch up” because the memory cache used for syncing works faster than the Fuze.

HOWEVER… when I got fed up with waiting on a VERY long playlist, I used CTRL-ALT-DEL / Task Manager to force Media Monkey to end.  Once free of MM, the Fuze changed from its “writing” screen to its “Connected” screen.

When I pulled it off the USB cable, the Fuze “Refreshed” its library and afterward everything was on there. No missing tracks. No missing playlists.

So… is the Fuze “catching up?”  Or is this more likely an issue with Media Monkey?

Can I SAFELY pull the Fuze off the USB cable while it says “writing” on the screen?  Or am I inviting trouble?



I had the same issue with my Fuze while using MTP mode. Now i’m using MSC and it doesn’t happen to me.

But does MSC transfer actual playlists, accessible from the Fuze?

And does MSC transfer ratings?

Not sure what you mean by the playlist but if the ratings are embedded in the mp3 files then yeah it will sync ratings.

I’ll do some experimenting with it this afternoon, but I mean the actual named playlist.  In some settings / with some other programs, the SONGS in the playlist will transfer, but the playlist itself will not.  So, if you transfer more than one playlist, you have no way of separating out the songs on the player.

What do you mean by “embedded” in the MP3 file?  How do you do that?

Hey Serminator,

I am having the same issue. Did you manage to transfer files as well as the playlists through MSC?


I’m having almost the exact same issue (Windows 7, 64bit), though I wouldn’t say it’s only happening with extremely large playlists, as 40 tracks in a playlist is quite an average number.

Media Monkey takes forever to transfer playlists in MTP mode, WMP11 and WMP12 simply stop after a certain track (the number of tracks they are able to sync varies, can be after the 2nd or the 15th with the same playlist).

Also, while transfering I’d better not touch any explorer window as the synchronization kills the process. When no files are transfered and the player is just connected to recharge, you can’t browse any files on the player through the explorer as it apparently takes too long to build the folder structur and the explorer process reports a time-out.

Same happens btw. in MSC mode.

Currently I’m trying to sync a playlist with 38 tracks and so far it took already 1h and 30min and I’m only up to track 36.

Media Monkey is not configured to auto-convert any tracks, the files are all mp3 CBR 320kbit/s with an average length of 3min.

So if anyone can figure out how to transfer files again in a reasonable amount of time, please post your solution.

You might want to check the Media Monkey forums, since that is third-party software and its most knowledgeable users are probably over there. What did you use to rip your files? Are you sure the tags are ID3v2.3 ISO-8859-1 ? Have you tried just sending the files over in MSC mode, drag and drop (not sync). I don’t use playlists, but the Fuze will work with .m3u playlists. Have you tried Winamp?