Joined mp3 files show faulty length

After 5 Years my Old Jam broke down.

I ordered a new one and now i have a problem i didn´t have with my old Jam.

When joining mp3´s via Mp3Merger the hour long Files will be shown to have the length of the first Mp3 File before merging.
I´ve tested with several joined audibooks.

So for example the first Mp3 File is the Introduction (Author, Title) which is 00:22 long and that is what the new Player shows as complete length, when in reality it is 9 Hours long.

It will also play the full file and then shows e.g. 00:30 and ticking away when the File length is just shown as 00:22 and i can´t skip anymore after.

I already updated to 1.16.

I tried to open the files via the Folder as well as the Audiobook function.

Anyone got an Idea what i could do to fix this?

(The side issue which I also experienced with my old Jam is, when there are over 127 Files in the Folder the player identifies File 128 as the first one, which is very annoying so i prefer having one large File for my Audibooks, also often Files get mixed up via the Audibook function but sometimes they are correctly sorted via the Folder function.)