Ixpand not working with a new iphone X.

I have a new iphone X and just bought an Ixpand 32 gig.  When connected the I get a message right away that states" I xpand drive would like to communicate with the ixpand flash drive.Ignore or allow."  Allow immediately gets an error " failed to connect to ixpand drive, please remove and reattach.  I have also deleted and reinstalled app.  rebooted phone.  Cant get it to work.

As a test, this drive will then plug right into my iphone 6 and work immediately.

Seems like an update glitch?

do you have the iXpand USB 2.0 or the iXpand USB 3.0?

iXpand USB 3.0

iXpand USB 2.0


Also has the iPhone X been reset? If so there is a bug in the current release of iOS that causes no storage devices to be detected after the iOS device has been reset. From what I have read this issue is resolved in the iOS 11.2 beta. 

Same , nor working with iphone x but work with ipad + iphone 7 …
Need fixed

I have the USB 3.0 version and it doesnt work with the iphone X.

Works with my iPad as the other user pointed out.

I also have the latest version of iXpand.  Still not working.

Sandisk: Just plug the usbstick to an iPhone X and you will see the error when you try to copy photos to the iXpand usb stick.

it is a hardware issue and cannot be fixed via a software update. the screen shot you posted clearly states to fill in the replacement request form. follow the link and request a replacement. 

I have the same problem with my iPhone X basically I get the same error message as the screenshot, and another problem … 

I bought two iXpand Mini when I was on holiday in Hong Kong thinking I would be safe with a product from a big brand like SanDisk, however, I stay in Singapore, and when I tried to fill up the RMA form, it says country not supported.

How can I get my iXpand Mini fixed via RMA?

Thanks a lot!

contact their support by email or phone.


Singapore Ask a Question 800-130-1859 Local Time
M-F | 9a.m - 6p.m
1 Like

I’m on the latest firmware and latest iOS, my iXpand mini doesn’t work with my iphone X too. Is it supposed to work with iphone x?

if the iXpand mini is ‘card 2’ type it should work

if it is ‘card 3’ then it won’t

you can check the card type on the sandisk app under ‘about’ or thereabouts

I RMA my 64gb ixpand mini, they didn’t have a working replacement for iphone X so they gave me the newer iXpand USB 3.0 (the one that ‘bends’ beneath your phone.)

Quick update, I spoke to their CSR and they helped to create an RMA number after I sent them images of my drive (I bought my iXpand while I was in Hong Kong), and I shipped my iXpand back to them in HK.

They sent me a new iXpand 128gb and it’s working perfectly now. I’m using iPhone X, so if any one has a iXpand that’s not working, it’s probably a hardware issue.

Thanks everyone for help!