iXpand not detected after ioS 9.3.1 update

What Firmware version is on your iXpand? If it is earlier than 4.4.7 you need to update it to work with iOS 9.0 (any version). I have linked the FW update tool for PC below. After you update it should work with the iPad running iOS 9.3.2. 


drlucky, your link shows “permission denied”

Not sure why. Try this link


Спасибо ,
я очень рад ,
после того , как все обновления работала
Спасибо вам большое



Thank you , I am very happy , after all updates worked thank you very much

Let me get this straight.

There is a SanDisk product designed to work with an Apple phone and it requires a Windows PC to update the firmware?

Please tell me there is a version for the Apple computer too.

no there is no update tool for Mac. If you have iOS 9.3.0 or 9.3.1 there is a bug in that version of iOS that may make the drive undetected by the app. This is an iOS issue and should be resolved when  apple releases iOS 9.3.2. 

Have ios 9.3.2 and not sync!!! Please help me!!!


1 Like

Totally lame. The iExpand Flash Drive is completely useless to me and I only find this out after having to borrow a PC to install the firmware. I know that you can’t be responsible for the OS but you should really try to be more Mac friendly. This was a total waste of my time and money. 

@velascoro wrote:

Have ios 9.3.2 and not sync!!! Please help me!!!


What Firmware version do you have ion the iXpand? With the iXpand connected on your iOS device go to Settings > General > About and scroll to the bottom. You should see the iXpand here. Tap the iXpand and check the FW version. If it is anything prior to 4.4.7 you will need to use the PC FW upgrade tool to upgrade the FW. After you have 4.4.7 it should work with iOS 9.3.2

PC FW upgrade tool


The iOS 9.3.2 beta 4 is public now. For anyone experiencing this issue and you are comfortable updating to a beta you can enroll and get the iOS 9.3.2 beta 4 at the link below. You will need to sign in with your apple ID and follow the instructions to update to the beta. 


If anyone is becoming irritated with SanDisk about this issue, please keep in mind that it’s really not their fault. It’s Apple’s.

I have iPad/iPhone flash drives from a variety of companies, including SanDisk, Lexar, Leef, and others. All of them are affected by this iOS bug. 

I went to the Genius Bar at my local Apple Store to try to get this cleared up and they had no better solution than “Wait for iOS 9.3.2.”


Have iOS 9.3.2

Have FW 4.4.8

And not sync. Any suggestion?

Thank you

can you be more specific about your issue?

1 Like

I did the iOS update from 9.3.1 to 9.3.2 expecting that this will be the solution for this issue (Ixpand can´t connect to Ipad device), Also I did the update of the iXpand FW from 4.4.7 to 4.4.8 with out success.

Please i you can help me to solve this. Thank you

make sure you are using the correct app. The one you need is iXpand Sync. If you are using that app start a new thread and post some screen shots. that will help us try to find your issue. 

My IXPAND still didn’t work in 9.3.2 too.
I tried with one IPHONE 5 and one IPHONE SE.
Continues useless.

How can I solve this ?


I used THIS:

-iXpand Firmware Update version 4.4.7 for iOS 9.0

-Using a Windows PC:

  • Download the  iXpand Update Tool for Windows PC
  • Plug the iXpand into your computer and run the tool.
  • The tool will recognize the iXpand.
  • Follow the wizard to complete the firmware update.
1 Like

I can confirm that installing iOS 9.3.2 fixed this issue on both a 12.9-Inch iPad Pro and and an iPhone 6S.

1 Like

I agree Sandisk does not have control of IOS releases, however Sandisk & distributors are selling this product without advising their customers up front their is an issue.

There is a word for that and it’s not blameless!!!

Hi all…

I bought a sandisk ixpand 32GB today by online.  Unfortunately, it’s not detected in my iphone 6s.  I am using ios version 9.3.2.  And the firmware version of my sandisk ixpand = 4.4.7.  

Anyone can help me why this device not detected?

Thank you,


please make sure you are using the correct app iXpand Sync latest version is 1.6.10. If you are please start a new thread and provide the device info make and model from settings > general > about from your iOS device. Screen shots of the app would also be helpful.