it's killing me and I'm ready to toss it out!

Ok - had bad tracks (though they played fine before) this is the 3rd time I have had my good tracks go bad

so we upgraded firmware and reformatted everything

looked OK

So I added music back

then it started freezing on refresh database

so I have been trying to connect in msc mode - no luck win XP with service pack 2 can’t read in msc mode

then I tried going into recovery mode to try using Sansa.FMT

it just says on my sansa screen enter USB 2.0 MSD mode

when I copy the file to the drive “16MB-FORMAT” nothing happens, when I turn off the sansa and turn it back on - I still get refresh database freeze issue

I am going insane have spent about 10 hours this time trying to get thie **bleep** thing to work.  About to toss it out - it has been very problematic.

  1. How do I get Windows to read in msc mode?  I have tried it on 3 PCs - are there downloadable drivers for this device because I CAN’T FIND THEM!

  2. Why is my Sansa.FMT not working?  This has worked before and now NOTHING!

  3. Why is this darn thing so complex - seriously is this really necessary for a device that only plays music and video?  My previous MP3 players worked like a charm - this thing is a nuissance!

HELP HELP HELP

BTW I have a sansa 8.0 GB Rhapsody

this is the clip board. you may want to try posting in the e200R board.

Message Edited by drlucky on 09-19-2008 03:44 PM