Issues with SANSA clip

I have a sansa clip 4 GB and after using it for a while, then charging it the screen keeps disconnecting from the computer that still recognizes it. So I have tried both ports, turning it on and off, changing its USB settings(after researching), and everything I could to get it to work, yet it keeps cutting out. I had it from MSC to MTP , but now it is on Autodetect - which made it a even BIGGER problem now and I don’t know what it is I’m missing here…I can’t get it to charge or anything…

Please I need help.

Thanks,

SOS 

Message Edited by SOS on 01-17-2009 06:02 PM

Message Edited by SOS on 01-17-2009 06:03 PM

Message Edited by SOS on 01-26-2009 10:59 AM

Hi SOS,

Hmm, you’ve tried using MSC as the USB transfer setting, you say? OK. Setting it to MSC is what helped me when I had problems charging the Clip.

What’s incredible is that I didn’t find any reference to this anywhere (no guide / instructions).

/Carl

Just saw this (nr 2 out of the FAQs). Maybe that will help?

*Perhaps I was using a USB 1.1 port when I had problems… maybe that’s why I needed to to switch to MSC for that port, I don’t know…*

Hey Calle, any ideas on my thread? Feel like I’m talking to myself in there too :smiley:

Ok, so I’ve already updated Windows Media Player and got the firmware running, but as soon as it finishes downloading for that it fails to catch any updates.

I had FINALLY got it to RE-CHARGE, yet it freezes up when it says “Connected” without showing user interface(menu).

No files can be transferred or be listening to and I’m still having some trouble… 

Thanks Calle, but I’m having another problem and that is it won’t let me go to menu options AND it takes even LONGER to switch the clip back on(sometimes it doesn’t even turn on at all, unless it’s plugged into its USB port)

Anybody got any other suggestions? 

:[

Message Edited by SOS on 01-26-2009 10:56 AM

Also,

 Should I just get someone to fix and pay the extra warranty?

I’ve only had this for 2-3 months…

if the player will not stay on after it is unplugged from the computer there is probably a battery wire that is broken. also you can not navigate the menu while the player is connected to the computer.