iPhone 6 Plus iOS8.2 Cannot access files!!!

Since I upgraded iPhone 6 Plus to iOS 8.2 I cannot get access to a files on WiFi Flash Drive.

I can connect the phone and  a flash drive. But whenever I tried to explore a files iOS App doesn’t show any! On iOS 8.1.3 - no problem. From macbook pro via Safari - no problems. iPad mini - ios 8.1.2 - no problem. JUST 8.2! Please fix asap.

Solved by myself. If you have the same problem:

  1. Delete settings for Sandisk WiFi Flash drive from iOS WiFi settings.

  2. Reinstall App from appstore.

3. Restart the phone.

  1. Turn on Sandisk WiFi Flash drive and connect the phone to it. Should work now!


thank you for posting the solution to the forum so other users that may have the same issue know what to try first.


I just solved this by myself on my Iphone 5 IOS 8.3. It took me over an hour to find out!

  1. Make sure the Wireless Flash app is close. 2. Go to Setting then Wi-Fi

  2. Pick your Sandisk wifi name then connect to it

  3. Once you got it connecting stay where you are then find the big “i” icon next to the singnal bar right of your Sandisk wifi name

  4. Write down the Subnet Mask number you see e.g

  5. Write down the Router number e.g 134.443.0.1

  6. Open Safari then type on the address bar the subnet number wrote then click Go, let it liad for a while about 20 sec

  7. Then stop the loading then replace the subnet number with the Router number then click Go.

  8. Now you should connect to your Sandisk wireless flash drive via Safari

  9. Try to browse a pdf file or something

  10. Open your Wireless Flash app

  11. Hopefully the magic comes true!