iOS 8.3 (version 2.1.1/ firmware: 3.4.1) crashes 90% of the time, even turns off my phone.

Yes, the app itself is crude (e.g: no searching, no arranging seriously?), and slow, but what on earth is this doing to my iPhone? It entirely freezes my phone with morbid black screen, then turns off my phone, and it won’t start up for a while…I’ve had an app or two that would cause some bugs, but not this proportion of intrusion. It makes this product beyond useless; rather corrupting. 

Please fix!!! 

I don’t have black screen but try this it solved my connection problem.

I just solved this by myself on my Iphone 5 IOS 8.3. It took me over an hour to find out!

  1. Make sure the Wireless Flash app is close. 2. Go to Setting then Wi-Fi

  2. Pick your Sandisk wifi name then connect to it

  3. Once you got it connecting stay where you are then find the big “i” icon next to the singnal bar right of your Sandisk wifi name

  4. Write down the Subnet Mask number you see e.g

  5. Write down the Router number e.g 134.443.0.1

  6. Open Safari then type on the address bar the subnet number wrote then click Go, let it liad for a while about 20 sec

  7. Then stop the loading then replace the subnet number with the Router number then click Go.

  8. Now you should connect to your Sandisk wireless flash drive via Safari

  9. Try to browse a pdf file or something

  10. Open your Wireless Flash app

  11. Hopefully the magic comes true!