"Installation Failed, Please Try Again Later" on 1.4.2 install

Sandisk 1.4.2 installed properly  . . . after havingf the same installation fail 5 times read numerous posts here,  heres how . . . The process requires uninstalling SanDisk DashBoard 1.4.1from the contol panel  . . . . and went went to > This PC > Downloads > uninstalled Sandisk set-up for 1.2.1 then open and installed Sandisk 1.4.2.

In othere word have the set up for 1.4.2 , unistall SanDisk Dashboard 1.2.1 and re install 1.4.2

Please have a basic PC knowledge before performing this operation ,DYOR


This is the procedure worked for me

  1. Install 1.4.1

After click finish 1.4.1 will open. Close it and close it from the tray too

  1. Again install 1.4.1 - this time install will unistall 1.4.1

  2. install 1.4.2

Hope it will work for everyone

1 Like

Thanks iLDaWg, that worked for me, when I tried installing and uninstalling the previous 1.4.1 version it just seemed to kick off and upgrade and fail.

But after I deleted that registry key the installation worked.

@kostasxanthakos wrote:

This is the procedure worked for me

  1. Install 1.4.1

After click finish 1.4.1 will open. Close it and close it from the tray too

  1. Again install 1.4.1 - this time install will unistall 1.4.1
  1. install 1.4.2


Hope it will work for everyone

it works.

I also found other way to install 1.4.2. without installing older version

in registry delete the key HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\SanDisk

btw im using windows 10 64bit pro so it may be somehow different key for other version of windows

*devs still need to create working unistall routine :confounded:

Tôi cố định cài đặt của tôi bằng cách xóa các khóa registry này cùng với các thư mục chương trình (Win10 Pro 64bit)

Major Geeks does NOT have 1.4.1, that I could find anyways.  

Google search comes up dry for downloading 1.4.1.

This is the only option that worked for me:




Posts: 1

Registered: ‎04-22-2016

Re: “Installation Failed, Please Try Again Later” on 1.4.2 install


‎04-22-2016 02:52 PM

The way I got it to work; after 1.4.2 failed, which it removed from the “Programs” list; was to delete the registry key HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\SanDisk  … Then 1.4.2 installed without any issues …

Message 74 of 78 (796 Views)

Add Tag…


This is the only option that worked for me.  Thanks a bunch  :D

I’ve fixed this problem on my laptop. Therefore, I’d like to share my experience here.

After clone my system disk to SSD via EZ Gig IV software, I found the Dashboard application can’t run properly.

When re-install 1.4.2 version, I also get the same problem.

I’ve tried to delete register keys, but the problem is still observed.

I found the Sandisk SSD Dashboard Service is existed on Services List(Control Panel  Administrative Tools  Services)

At first, I tried to delete this service via below command:

  sc delete “SanDisk SSD Dashboard Service”

Second, I removed the below register key:


Finally, reboot my laptop.

After that, I could install the Dashboard appliation without any issue.

V 1.4.2 does not install correctly on Windows 10 Pro 64

Many thanks.

I had the same problem when installing the update. What I did was to click on MY Computer, Open the files, click on Programs and there was the SanDisk Dashboard, I clicked on the file and the program installed without any problems.

Hope this works for you.

Hi Everybody,

Just glanced thru the remarks and were all having much the same problem.

I’m runing windows 7 Home Edition, I had major problems trying to register the Waranty and Disk.

I eventualy got a phone call from SanDisk. I gave them the details of my disk and the type of windows I’m running,

but to no avail…

I left it with them they sent me an email telling me I was registered with an attachment.

After getting the Dashboard up with full functioning Screen, another mail arrived for a new upgrade which I downloaded, back to sqaure one.

No matter how I try I get no joy, I was advised to reload my older version, which I have I now sit and wait for further instructions after sending off a file in text of my operating system, plus screen shots of the Dashboard to help them diagnose the problems I hope!   

I can’t believe that SanDisk still does not seem to be able to put together a working updater. Version 1.4.3 brings up the same problems like 1.4.2… Installation failed error. Seriously, how hard can it be.:confounded:

Again I had to revert to 1.4.1, deinstall it and then install 1.4.3 to make it work

 For anyone having problems installing 1.4.3 here is what I did to install it.

  1. After 1.4.3 failed I went back to 1.4.1 with the installer file I had saved from before

  2. After 1.4.1 was fully installed I went into “Programs and Features” in Windows 10 and tried to uninstall SSD Dashboard

  3. But instead of it uninstalling when I clicked uninstall it actually started installing 1.4.3 and that worked somehow.

 I dont know if this will work for anyone else, but its what I did to get 1.4.3 installed fully with no errors. This is on an Acer R5-571T Laptop with Windows 10 64bit.

This is an easy one.  Go to the download location, right click the download, select run as administrator.  Installs fine.

@georgealon wrote:

Please uninstall your current version and make sure the SanDisk folder under “Program Files” or “Program Files (x86)” is clean.

When installing version 1.4.2, make sure the file “SanDiskSSDDashboardServiceSetup.msi” is present in the SSD Dashboard folder and that looking at the properties, the digital signature is from SanDisk and valid. Somehow that disgital signature was incorrect with the previous installer. Please report any issues regarding this, for example if you see an invalid digital signature. Thanks  

This solved the installation issue for me. I’ve deleted the Sandisk folder in Program Files (x86), ran the installation again and it worked. Thanks!

I have tried all the methods but still failed to instal 1.4.3 Win 10 x64

Where is SanDisk official support???

georgealon are u from oficcial support?

Please contact our support center for step by step procedure to solve this issue.

For anyone who wants the download link for version 1.4.1, here it is: