"Installation Failed, Please Try Again Later" on 1.4.2 install

1.4.1 version:


1 Like

I also have Windows 10 Pro and it fails for me as well.

Going back to the previous version works for me.

I have now tried every possible way I have read to uninstall and reinstall to make it work.  For me, none have been successful.  I have erased all downloads, removed everything from the sandisk folder (with or without the msi file), cleared all caches, etc.  I would suggest that SanDisk reach out to one of us that is having no luck and walk us over the phone to see if they can get it to work.  Then that process can be posted here. SanDisk has our emails on file.  


I can help you directly if you like. Send me your contact via private message.

I fixed my installation by deleting this registry key along with the program folder (Win10 Pro 64bit):


Seems something in there is not liked by the new version.


Ok, Thank you for publishing 141 again.

Installed 141, uninstalled it, and then 142 installs normally.

Everything ok.

Windows 10 Pro 64 in Spanish

deleting registy keys works ! thanks… HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\SanDisk

Removing the registry key worked, thanks!

Worked like a charm, thank you! 

I kindly confirm the BS workaround! :slight_smile: You need to re-install the previous version, then uninstall it from the Windows programs list. I restarted my computer just to be 100 % sure then proprely installed the newest version. Somehow the installator cannot handle the task or proprely removing the software. so the uninstall is incomplete and unless you do this workaround, you will never be able to do so. Sandisk, please fix this though, because the average joe will never reach this forum.

1 Like

Uninstall from the control panel of 1.4.1 doesn’t uninstall 1.4.1, it seems to trigger installation of 1.4.2.  No joy here.  Reverting to 1.4.1 until Sandisk figures it out.


SUCCESS.  Deleting the sandisk folder under Programs(X86) combined with deleting the registry key let me install 1.4.2 without having to reinstall 1.4.1.  Hopefully this helps sandisk sort out the installation issue, they don’t want the general user population editting the registry to make their software work! 


First, this shouldn’t have been rolled out in the first place. Second, I shouldn’t have to read through seven pages of forums to find possible fixes.

That said, thank you georgealon for providing a sanctioned download for v1.4.1, since most normal users will need it to fix this problem. (shouldn’t be buried on page 6)

After encountering this error and reading all these pages, I ran the v1.4.1 installer. I closed the dashboard and uninstalled using the ‘Programs and Features’ uninstall. This didn’t work for me and I never found an .msi file.  I re-ran the v1.4.1 installer and it was automatically in Uninstall mode. I completed that and checked the C:\Program Files (x86)\SanDisk\SSD Dashboard folder. The only thing left was a folder named “smart”. I was then able to successfully install the v1.4.2 dashboard. 

File checksums

(v1.4.1) SanDiskSSDDashboardSetup.exe md5: 860149c66ee850faaa4edd96f2cf53d3

(v1.4.2) SanDiskSSDDashboardSetup.exe md5: e4adaa96bfa36165007fa4d1dc0f27d1

Until support assembles an installer capable of properly uninstalling v1.4.1 and fixing this mess, this forum needs to sticky the workaround (mine or someone else’s) or say you’re working on the problem.

tl;dr   If you get this error, download the old version 1.4.1 dashboard installer.[link] Run it, then close the dashboard. Right click the dashboard icon in the lower right systray and exit. Run the v1.4.1 installer again. It will say “Uninstall”. Then run the new v1.4.2 installer.[link] Done.

I looked everywhere on how to send a PM and could not find it.  Where is that in this forum?


best, and most consise, message I found about “Installation Failed, Please Try Again Later” on 1.4.2 install.  

Followed the 4 step process of:

1 install SanDisk 1.4.1

2 close the dashboard, and in the system tray also

3 install SanDisk 1.4.1  (actually --> Uninstalls  <-- the dashboard)

4 install SanDisk 1.4.2

Worked like a CHARM.  I had been beating this beast for 2 hours of reading the forum, installing, uninstalling, looking for registry entries… AAUUUGGGHHHH!

Your right it SHOULDN"T be buried on page 7.

Thanks again.

1 Like

That worked for me !!!

Worked perfectly, thank you…

The way I got it to work; after 1.4.2 failed, which it removed from the “Programs” list; was to delete the registry key HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\SanDisk  … Then 1.4.2 installed without any issues …


Sandisk 1.4.2 installed properly  . . . after havingf the same installation fail 5 times read numerous posts here,  heres how . . . The process requires uninstalling SanDisk DashBoard 1.4.1from the contol panel  . . . . and went went to > This PC > Downloads > uninstalled Sandisk set-up for 1.2.1 then open and installed Sandisk 1.4.2.

In othere word have the set up for 1.4.2 , unistall SanDisk Dashboard 1.2.1 and re install 1.4.2

Please have a basic PC knowledge before performing this operation ,DYOR