"Installation Failed, Please Try Again Later" on 1.4.2 install

Thank you so much paulyates :wink:,

This is the only method that worked for me.

Now, I use the latest version of Sandisk SSD Dashboard, the 1.4.2 version.

georgealon : your installation tips don’t work, first because the installer file isn’t a msi file, but it’s an exe file. Then, even if the SanDisk folder under “Program Files” or “Program Files (x86)” is clean, the installation failed. I don’t know what exactly what it occurs, and why the installation failed each time.

My computer run on Windows 10 Pro 64 bit with a Sandisk Extreme Pro 960GB.

Good software M. Sandisk, usefull and essential to any owner of a Sansdisk SSD.

1 Like

There is no msi file and folder is still there after failed install.

1 Like

@lepa71 wrote:

There is no msi file and folder is still there after failed install.

Do the same things that @paulyates  do, it’s worked for me.


I re downloaded 1.4.2 from http://kb.sandisk.com/app/answers/detail/a_id/15108/

Uninstalled 1.4.1 using win 10 control panel.

Ran the downloaded software BOOM! the .msi file appeared in C:\Program Files (x86)\SanDisk\SSD Dashboard and the install completed.


1 Like


1 Like

I’ve tried everything and ver.1.4.2 won’t install no matter what I do.

So I will stay on ver. 1.4.1 and will never buy another SanDisk product again,Since you all can’t release a working ssd monitoring software.

1 Like

I’m having the same issue with the update. I’m sure Sandisk has already recognized and is working on the issue, but just posting here so they awknowledge it’s not just a small percentage having problems with the update.

Also, I wanted to point out that I reverted back to 1.4.1, so that I might do a clean uninstall in preparation for 1.4.2, but now I can’t uninstall 1.4.1 – it just gives me the option to install the update, which of course fails. I’ve tried uninstalling using the Control Panel, and by executing the official “uninstall” shorcut from the SSD Dashboard folder.

1 Like

it works! :smileyvery-happy:

windows 10 Pro 64 bit

installed back version 1.4.1 than uninstalled manualy and installed new one 1.4.2 no problems!

if you don’t have a 1.4.1 copy just download it from


 but select :downloads@MajorGeeks not authors site

1 Like

"paulyates wrote:

So, I finally got mine working after numerous failed attempts. Here’s exactly what I did…

  • Download dashboard 1.4.1 from Major geeks and install.
  • Close dashboard (from system tray too),
  • Use control panel - Programs and Features to remove version 1.4.1.
  • Install 1.4.2

No other actions between these steps (IE No need to reboot etc).

I can only assume that the 1.4.2 upgrade does not remove everything it should when it deinstalls 1.4.1"

I can’t deinstall  1.4.1 - When I try to remove v1.4.1 it installs 1.4.2 with the known eror message.


solved (Windows 10 x64)!

the main problem is that you can not really install and deinstall 1.4.1 because the setup file under C:\Program Files (x86)\SanDisk\SSD Dashboard will be automatically replaced with 1.4.2.

-  install 1.4.1

  • go to C:\Program Files (x86)\SanDisk\SSD Dashboard and replace “SanDiskSSDDashboardSetup.exe” with SanDiskSSDDashboardSetup.exe 1.4.1 setup file.

  • run deinstall

  • install 1.4.2

1 Like

Ok, I finally get it. I downloaded the 1.4.1 and after installing 1.4.1 over 1.4.1 the installer ask me to deinstall 1.4.1. Complicate? Yes :slight_smile:

After the deinstallation process v1.4.2 was able to in istall.

The next time it would be nice if Sandisk makes a better job!

1 Like

I’ve tried everything. It did not work for me. Even installing version 1.4.1 now gives me the same error message. I’ve tried removing every reference to Sandisk folders and files and the only remaining file with I can’t remove is the Sandisk SSD Dashboard Service version 1.0.1. I’ve never encountered a software that is so difficult to install.

Sandisk should publish the 1.4.1 version in its site, or a new and correct 1.4.2.


Version 1.4.2 had a wrong digital signature included and we did correct the issue. The new 1.4.2 was replaced on our cloud server. You will need to download the new 1.4.2 from SanDisk Support page. To make sure you receive the new file, you’ll need to reset your cache, or remove all occurance of the previous file on your system. Please try again. Many people got through successfuly …

I have just downloaded (withour cache, etc), restarted the PC before installing, with exactly the same result (can’t install). I have Windows 10 Pro 64.

Why don’t you publish old versions to allow trying the method described above? Regards.

1 Like

1.4.1 version:


1 Like

I also have Windows 10 Pro and it fails for me as well.

Going back to the previous version works for me.

I have now tried every possible way I have read to uninstall and reinstall to make it work.  For me, none have been successful.  I have erased all downloads, removed everything from the sandisk folder (with or without the msi file), cleared all caches, etc.  I would suggest that SanDisk reach out to one of us that is having no luck and walk us over the phone to see if they can get it to work.  Then that process can be posted here. SanDisk has our emails on file.  


I can help you directly if you like. Send me your contact via private message.