I'm getting a lag with audio playback on my Sansa clip+


Everything works fine on normal volume… but I’m getting a lag when I’m playing at high voulme. I bought my Sansa clip+ recently with new firmware. How can I fix this problem? Looking forward to your replies.



You might try reapplying the latest firmware, in case this is a corrupt software code issue.  See the firmware upgrade sticky thread at the top of the forum. 

I’ve just updated my firmware too, but still getting the same error. It’s still lagging on high volume.

What is it (format) that you are playing?

.mp3 format. Isn’t there a solution for this?

@cybercriminal wrote:

.mp3 format. Isn’t there a solution for this?

That’s extremely weird. I know FLAC & OGG take more processing power, so it could be to blame for slower play-back at higher volumes. In fact, I remember a long time ago when these formats were first added in a firmware update (for the Fuze) that people reported this very thing.

But .mp3 shouldn’t be a problem; are you using a heavy-handed Custom EQ setting? Where did the files come from, downloaded or ripped from CD? If you ripped them, what program and bit-rate setting did you use? Are the files in the internal memory or on an external memory card? Do you have ReplayGain settings applied?

Something’s got to be different about your settings and/or files. This isn’t right.

Thanks for the quick reply. I’m having only 7 songs in my Clip+ 2GB and all the files stored in internal memory. I set the EQ to normal. I download these songs from various sites and in 320kbps bitrate. ReplayGain is OFF.

I can enjoy the songs at normal volume, lagging only on high volume. I updated my firmware too. Do I need to do anything else? :frowning:

UPDATE: Those songs have ID3 tags. So, is it causing this problem?

Getting the same prob. with 128kbps songs. I even tried completely removing all of the id3 tags. :frowning:

UPDATE: I’ve done a format and updated with the latest firmware. This fixed my problem.

I just inserted my Nokia MicroSD into my Clip+ and its frozen now. I’m unable to turn it off. What should I do now?

You definitely have a

here. This is not normal behavior, and millions of people enjoy their mp3 files at very loud volume. I would guess there’s a hardware (processor) issue going on here and that should be covered under SanDisk’s warranty. I’d call them up.

SanDisk Tech Support

Yea! I fixed my problem by updating to latest firmware.

I’ve got another problem… I just inserted my Nokia MicroSD into my Clip+ and its frozen now. I’m unable to turn it off. I’ve tried connecting to PC… it doesn’t work. :frowning:

Thanks Mikerman and Tapeworm for the help. This tiny clip+ is amazing. Now I can listen to songs on full volume. Good quality and amazing player. I’ve no issues now. Lastly, I want to know which Micro SD cards supports Clip+.

Great to hear!

As to microSD cards, all should work.  Having said that, every now and again, you hear of one that doesn’t play well with the Clip, for inexplicable reason.  I don’t know that there is a pattern, though–although, watch out for fake cards (such as small capacity cards pretending to be larger capacity cards), such as sometimes on eBay.  I’ve been fine with SanDisk and lesser-expensive Polaroid cards.  Personally, I’d only buy from someone who accepts returns, in case there is an issue, a business or local store with a good return policy being best.

CyberCriminal wrote:

Yea! I fixed my problem by updating to latest firmware.


Glad it’s working for you, but didn’t you say earlier that you had already upgraded the firmware and the problem persisted?