id3 genre displayed as unknown

Hi, i’ve tagged a bunch of mp3s with easytag v2.1.4 under ubuntu v8.10 using id3lib v3.8.3 and libid3tag 0.15.1 

When i tag a file with the genre ‘Synthpop’ (which can be found default in easytag) using only id3v2.3 iso8859-1 character coding (no id3v1 etc), and i transfer this file to Fuze v01.01.22F than the genre is displayed as ‘unknown’ in every occurence even after a database file delete.

Are there a list of specific genres in id3v2 or is it freetext?

It should be open for what ever you want. I put some on my fuze using mp3tag and windows with the genere as crappy. and It shows up.

No, there’s no preset genres you have to use.

Try using another ID3 editor, (like maybe right clicking on the MP3 and selecting “properties”, or whatever the option is for Linux users) or changing the genre from “synthpop” to “synth pop”.

I have those library’s and use EasyTag on both Ubuntu 8.04 and 8.10. I can tag with any freetext I want. I tried

  1. IDv2.3 with ID3v1.x turned on
  2. IDv2.3 with ID3v1.x turned off
  3. IDv2.4 with ID3v1.x turned on
  4. IDv2.4 with ID3v1.x turned off
    All of the combinations displayed on the Fuze with no problems.

Can you open EasyTag, go to “Settings -> Preferences -> ID3 Tag settings” and give us what options and what settings you are using?

Message Edited by hazza on 02-08-2009 07:32 AM

As far as I know, it only says Unknown when there is no genre specified, or perhaps if it can’t read it.

I see you are doing the Hungarian translation, forgive my ignorance but does the hungarian language use any of those weird characters like backwards R’s the Russians do?

If you are using them then the Fuze might be refusing to read the tag.

hazza: :slight_smile: yes, hungarian language has some weird characters unfortunatelly: accents like áéíóöőúüő and digraphs like cs dz dzs gy ly sz ty zs.

But I may be the one and only person who still types everything without accents simply because it’s my habit since the c64-era when you didnt have your own accents. And yeah i got found about this time to time by the Keepers Of Hungarian Culture.

Secondly i do not listen and i do not have any hungarian music. Hungarian artists and their music are utterly deeply bad. We make quality products but that is definitely not the music.

OK, i’ve made some test and tagged a short mp3 with the setup described above.

easytag settings: NO write id3 to flac,  OK strip blank tags, OK auto convert old id3v2, NO use crc, NO use compress, OK write id3v2, id3v2 version 2.3, id3v2 charset: other iso-8859-1 TRANSLIT, NO id3v1, read charset standard

I’ve tagged the test file with 3 different genre and paste the header in hex and text here:

easytag: Electronic
49 44 33 03 00 00 00 00 06 3A 54 43 4F 4E 00 00 00 05 00 00 00 28 35 32 29 00 00 00 00 00 00 00
fuze: Electronic

easytag: blablabla
49 44 33 03 00 00 00 00 06 3A 54 43 4F 4E 00 00 00 0A 00 00 00 62 6C 61 62 6C 61 62 6C 61 00 00
fuze: blablabla

easytag: Synthpop
49 44 33 03 00 00 00 00 06 3A 54 43 4F 4E 00 00 00 06 00 00 00 28 31 34 37 29 00 00 00 00 00 00
fuze: Unknown

It is clear that ‘Synthpop’ is a default genre -like i suspected it before- with the code of 147. By wikipedia there is such a list but it is used in id3v1 and represented in a single byte not in plain text between brackets. Here is a list of genres. Another list.