I need power source to "kickstart/wake up" the Clip+ ... Anybody experienced this?

Hi. Has anybody of you ever experienced this? Is this a known error which sometimes occurs within this product line?

When I bought the Clip+ everything worked as expected. For a couple of weeks. But now, I cannot turn it on anymore. No matter what buttons I press, it doesn’t “wake up”, the display stays black and I cannot hear any sound.

OK, I thought, maybe it is dead or at least the internal battery is dead. But mysteriously enough, this is not the case! When I connect my external power supply (2x AA to USB emergency charger) the Clip+ wakes up and works without any problem. And funny enough, the battery displays “full”. I thought this could be an error, but I went jogging with it for 2 hours (without external power supply of course) and when I came back home, the Clip+ was still running. So the battery is not dead either.

… but what is it?

And more importantly, can I fix it somehow? It’s not comfortable to always carry an external power supply with me just to “kick start” / “wake up” the Clip+ before I can use it …

The player is still under guarantee because I just purchased it a couple of weeks ago, so I can always send it in for replacement, but of course I wouldn’t if it’s not necessary, so I thought I ask the professionals around here …

Many thanks for any help.

Cheers, Chris

Sounds like a hardware problem.    The clip+ shouldn’t need a jolt for it to wakeup and get going if the battery is well charged.

Oh nooooooo … I’m so embarassed. :stuck_out_tongue::stuck_out_tongue::stuck_out_tongue::stuck_out_tongue::stuck_out_tongue::stuck_out_tongue::stuck_out_tongue::stuck_out_tongue::stuck_out_tongue::stuck_out_tongue::stuck_out_tongue::stuck_out_tongue::stuck_out_tongue::stuck_out_tongue:

I realized what the problem is.

I think it’s the most embarrassing and stupid thing that ever happened in my life, so I’d rather prefer not to talk about it (and if possible delete this thread) … . :stuck_out_tongue::stuck_out_tongue::stuck_out_tongue:

But anyway, the problem is solved.

Thanks for your help, mags1230.

Oh c’mon, you gotta tell us! We promise we won’t laugh [much].

Let me guess . . . the 1 button you didn’t try pressing was the Power button on top of the unit?


Well, it wasn’t exactly difficult to guess anyway … I mean, what is the most stupid thing one can do when trying to power on a device … ?? You are spot-on Tapeworm! I forgot about the power-on button and pressed “play” (and all other buttons on the front).  :smileyvery-happy::smileyvery-happy:

To my defence, I have to say that I had the Clip for a long time and used it almost every day, and as far as I can remember it didn’t have a power-on button, but you turned it on with the play button. It became anchored deep-down in my subconscious mind and now it’s kinda hard to change habits …

… well, at least I figured it out on my own, still embarassing enough, but imagine one of you guys would have had to tell me to press the power on button … :wink: :wink: :wink:  I think that reduces the 1000 days of shame for me to something like 990 … :-))

Good to see it worked out for you, finally!  And this is a good reminder of steps to make sure have been completed–I also have a separate player that has a combined play/on button.