I need a free program to organize the files!

I just got my Fuze and I transfered a few songs (drag and droped in explorer) but when I tried to access them in the player it often told me an artist was “unknown” for a file, even if many other files on the same album were recognized. I know this is a tagging problem, but windows can’t change the tags. I tried windows media player, that won’t let me change them either as far as I can tell. I NEVER had this problem with my Creative Zen, it told me these same files were recognized, and the media program it came with could easily manage them. Unfortunately that only works for Creative products, so it’s no use to me here.

Also I tried using the folder system instead of the tags and I had another REALLY stupid problem. It would let me name the folders in explorer, but when I access them on the Fuze I get corrupted folder names. Often they would retain the “new folder” name instead of what I named them, but also I’ll get a bunch of BINARY numbers in the name! Why??

I’ve had this player for 2 hours and I’m already really frustrated.

Oh, and yes I updated the firmware already.

[edit] Trying to install rockbox, having trouble of course. **bleep** program won’t even detect my player. Also looks like I can’t return this thing ;_;

1.) You’re having the ‘naming’ problems and cannot install Rockbox because you are in MTP mode. I don’t know exactly why, but this mode can be problematic re-naming files. Rockbox only works in MSC mode. I would advise formatting the player (in Settings > System Settings < Format) which will erase everything on it (not firmware or operating files) so you can start over. Switch the player to MSC mode (don’t use the Auto Defect setting), plug back into your computer and drag & drop away. Your files will retain the same names, and you can install Rockbox if you wish. Although I would advise against this until you get a little more used to the player as it is. Now you can also use the Folder navigation in the Music menu to find & play your files if you wish, or you can . . .

2.) Download & use MP3Tag to edit and correct your tags. It’s simple and it’s free. Set the Write default to ID3v2.3 ISO-8859-1 and re-save the files. Then transfer to your player. Now they won’t be listed under ‘Unknown’ and you can navigate via the player’s lists (populated by the ID3 tag info) to find and play your music; no Rockbox needed.

Oh cool, I figured there just wasn’t a solution. Thanks. I forgot to mention this is a refurbrished device, so it’s not brand new. Anyway, I’m working on it to see if this solves things, but it should at least help.

[edit] Now the folders work! Yay! And now the player doesn’t! Ha! It’s freezing up and skipping. Oh well, that’s why it was refurbrished I guess. Still have to return it, which makes me sad because it’s such a nice little player when it works.

@sarahofborg wrote:

[edit] Now the folders work! Yay! And now the player doesn’t! Ha! It’s freezing up and skipping. Oh well, that’s why it was refurbrished I guess. Still have to return it, which makes me sad because it’s such a nice little player when it works.

Whoa! Don’t get in such a hurry to get rid of that little jewel. Freezing is caused by either bad ID3 tags (which I told you how to fix before with MP3Tag), or corrupted audio files. Skipping can be caused by the same 2 things, but more probably corrupted files.

I doubt very seriously that these problems are caused by the fact that your player is refurbished. So you’ve got some work to do . . . edit those ID3 tags, and use ChkDsk to check for ( and hopefully fix) any files that are corrupted. It may not work, but it’s worth a shot. If not, you will probably have to replace them. Easy enough if you ripped them from CD’s; a little more complicated (and expensive) if you bought & downloaded them online.

The downside of the Fuze is that it is too picky about tags.

Get mp3Tag, let it add itself to context menus on install  and set the Write default in Tools/Options/Tag/Mpeg to ID3v2.3 ISO-8859-1

With every album I put on the Fuze, I first open it in mp3tag, (Right-click on the folder, mp3tag is among the options). Make sure the files are in playing order, top to bottom. (You may need to click on the Track header.) Highlight them all, go to Tools/Auto-numbering Wizard and choose the Leading Zeroes option. This will number the files 01,02, 03 and save them as ID3v2.3 ISO-8859-1 tags.

Takes about 5 seconds. No more tag problems.

Skipping files may mean the file is a format the Fuze won’t read. Usually the culprit is m4a or m4p files from iTunes. You need to open those files in iTunes, highlight them and, under Advanced, Create mp3 version. Or you can use other converters, like Media Coder.

Since conversion lowers fidelity, say goodbye to the iTunes store and buy mp3s from Amazon or eMusic instead.

And by the way, if you want a free program to organize files, try Media Monkey. You’ll need to replace the free version’s limited-time mp3 encoder, lame_enc.dll with a permanent one, like this one: http://lame.buanzo.com.ar/

Sorry, already returned it. But I know the files are fine, they play fine on my computer. They’re regular MP3 format. They also play just fine on my other player. I honestly think I got a defective player.

Thanks anyway, I suppose there’s no reason for me to post anymore now that I don’t have it.

“They play fine on my computer.”


Your computer has a faster processor, more memory, more elaborate media software, more capabilities built in.  It’s also, not coincidentally,  bigger than the palm of your hand.

Little electronics make compromises. One that the Fuze probably should not have made is that it can only handle certain tags. Here’s hoping that your files play on your new player, which probably has different quirks–but guaranteed, it has some.