I don't see anywhere how you decrypt and transfer files off of Sandisk Secure Access

I have same difficulty as OP and don’t see that the reply is helping .

I have new Sandisk Extreme Pro 128 GB and have copied onto this stick a number of folders with personal files which I intend to keep with me while travelling . Naturally , I want that info secure .

If I put stick into PC , all info is open to see on Windows Explorer . Any file can be opened without password .

Even if I have dragged a folder to the Vault area , same thing - folder can be opened and any file accessed .

At no point am I asked to insert a password except when running the exe file during set up . 

I have tried reinstallation a few times , and only time I get asked to insert a password is during setup .

The user guide does not advise how to encrypt files , I just don’t get it .

Clearly the OP and myself are missing something “obvious” ?

Many thanks !

Re: I don’t see anywhere how you decrypt and transfer files off of Sandisk Secure Access

‎03-10-2014 11:07 AM

Just copy the file from the application back to the computer. The file is decrypted automatically

Does not work by copy files back to computer.

Any other suggestions?

Kaybee, I am having that same problem. Just downloaded and installed the app. Created a password and dragged several files into the vault. When I click on the “vault”, it opens (without asking me for a password), and the files are completely readable. It is just another ordinary folder on my USB Drive. No security, no encription! Instructions in the “Quick Start Manual” are useless.

Someone tell us what we are doing wrong please.

I have the same problem.

I can not copy from the flash drive to the computer.

They can tell me how?

Si me pueden contestar en español, mejor.

My problem I think is similar to those already mentioned.  When I copy files into SecureAccess 2.0 vault there is no problem but when I try to pull a file out of the vault, my file is an Excel spreadshet it fails.  It fails in a particular manner, inside the vault my file is 14 kb in size but when I copy or move this file out of the vault the size shrinks to 2 kb and I receive this error message:

" Version Incompatility - Incorret File Version".  Sounds to me like the file is not being decrypted correctly.

What do you think?

The support from SanDisk is just wonderful…NOT.  why don’t they answer this question?  i was able to transfer 1 folder off the SanDisk but onto the computer, but not any more of them. It’s crap.  If I can ever get them off that thing, I will take a hammer to it when I am finished.  Very frustrating

I think they want to be sued and finally they have found someone who could do that.

If there will be no solution for this problem in two weeks, i will give the precept to my advocate for starting the court progresses, seriously.

I had the same problem but was able to get through it by doing a drag and drop. The trick was to drag the file over to where you are pasting and continue holding the right mouse button until the cursor turns into what looks like a folder (sort of) and then release. It wouldnt decrypt and move the file without the holding of the button. Hope this helps.

It didn’t work for me. I simply copy the encrypted .dat file from my vault to another location. Please help. My father just passed away and there are documents (birth certificate, DD-214, etc.I encrypted that I need access to, NOW. I am practically begging.

:smiley:   Hi Abby Britton,

Dear member of SanDisk Community, welcome.

1-  Not change the location, nor either the name, of the  folder [SanDiskSecureAccess Vault], that contains the encrypted files.
This folder , must be at the root of the UFD (USB flash drive or pendrive), to run.

2-  To extract a file it out of My Vault, select the file, and in toolbar, click on File, then “save to”.

3-  There are, an option, in the toolbar My Vault, _ which generates Backup _ (for SandiskSecureAccess Vault ), to your PC.

4-   Please, _ read carefully , the following article,_ in link:


Luck, and then you tell us, what happened, please.

Regards, Alfred.                                                             (Google translated)

I am still having no luck decrypting my files, which were generated from a variety of applications in a number of file formats. I’ve gone so far as to trowl the hackers’ websites looking for ways to crack the encryption so I can get my files back. I have tried everything the other forum users recommend, but their solutions don’t work for me. This is very frustrating to think I have lost forever my most important and precious files. I suppose the lesson is “save the important stuff to a memory stick and put the stick in a safe.” Too bad, I’ve been a loyal user of SanDisk products.

No luck. When I follow the instructions, which I read carefully, specifically " 2-    To extract a file  it out of My Vault, select the file, and in toolbar, click on File, then “save to”, the encrypted file is copied to the location I specified in “save to”. I remain unable to access my encrypted files.

:smiley:   Hi Abby,

Well, the last thought that comes to mind is the following.

I think the application is corrupted. By both, the we will change.

Then, please, try this:

1-     Download (free), the application, SanDiskSecureAccessV2_win (7 MB), and copy the downloaded file, into another empty Pendrive (N° 2).

Link: http://downloads.sandisk.com/downloads/SanDiskSecureAccessV2_win.exe

2-     Install (click / open) with the same data (username and password), that you used in the previous Pendrive (N° 1).

3-     Then of doing this, you will have in the Pendrive (N° 2), two files:

3.1- SanDiskSecureAccessV2_win, (the application).

3.2- SanDiskSecureAccess Vault, (which is the folder, that contains the encrypted files).

4-    Then, copy of the previous Pendrive (N° 1), the folder, [  SanDiskSecureAccess Vault  ] which must have exactly this name , and you replace, _the folder of the same name, that you have in the new Pendrive _ (N° 2).


Regards, Alfred.                                                                           (Google translated)

Okay, Folks, here’s how it’s done.

  1. Launch SanDiskSecureAccess and enter you password.

  2. Your files will be shown at top with their unencrypted names.

  3. Simply double-click your chosen file and you can now read it.

  4. Depending on the format, copy or save-as to another location.

Thanks for the post. It was the first clear and cogent reply I’ve seen. Unfortunately, double-clicking did not work for me. My data is gone forever. That’s that. Thanks again. 

That’s too bad Abby.

You might want to do a test file to see if this is working. I assume you’ve resolved the matter using other means. Here’s my thoughts on whether to encrypt.

Generally, some people never keep their stick plugged in, especially online. Rather, they keep it hidden in a secretive place depending on the level of sensitivity, and may not encrypt the data at all. On the other hand, if the stick is carried about with the possibility of being lost or stolen, or contains serious documentation, then it would be wise to do both, i.e., encrypting and enshrouding the device beyond detection of its presence. In extreme cases, you can encrypt at least one character of your password by using a foreign letter you cannot type. But, the ability to remove the flash-drive is well enough for common security.

As for the lost files, something may have gone wrong during the encryption process. Perhaps, cutting these files from the vault folder and temporally pasting them elsewhere, then reverse the action by cutting and pasting back into the vault may work. Do this procedure without logging in. Normally, I usually leave a copy of an unencrypted file before encryption. If OK, I then overwrite (not delete as nothing is truly deleted) the original with a blank file which can be used for other data later on. Hope all of this helps.

Thank you. I’ll keep trying, but only now that I have your encouragement.

Well, I’m no expert and apologize for sounding like one. Since the ‘80s I’ve seen computers do crazy things, yet have learned many tricks along the way. I don’t know why it works, but the removal and reinsertion of a file deceptively, has saved me many times with other applications. I can only guess something in the encryption process went wrong. If you can’t open the file at all, it’s not recognizing the .dat file name that was generated. Then, too, if it opens and all you see is encryption then somewhere the format on which the original was written unintentionally affected the procedure. Believe it or not, on a weak file encryption that has a unique extension, the contents can be copied and pasted to Notepad and be read. I tried this with one of my files and found the text to be of Chinese. In translation, a few names popped-up along with other words I did not write. But, I must point out, that if I knew of a way to read your files it would be unethical and illegal to post. However, keep the files and play around. I’m 66 and over the years I’ve seen people with little knowledge accidently solve complex problems.

BTW, I mentioned encrypting passwords with a letter that cannot be typed. This means with the use of standard fonts enter a key-code. When you look at a character map each block with a letter outside the normal keyboard has a code. Some blocks are empty but have a code. For example: in a situation where you cannot separate two words with a space, you can enter a blank character (no-break-space): abbybritton would be entered, abby Alt+0160 britton = abby britton. But, look on the bright side. Testing the encryption first before you dismiss the original is a good idea. And in a truly severe case, I still transfer data to a disk only I know of its whereabouts. Good Luck! :smiley:

I found a workaround. I needed to copy files from one laptop and move them to a new machine. Here are the steps to decrypt your files:

  1. Open the USB drive where your SanDisk is located. For me, it is (USB Drive D)

  2. Locate the file SanDiskSecureAccessV3_win.exe

  3. Right click the file in step number 2

  4. Click on the bolded Open prompt at the top of the menu that appears

  5. You will be prompted for your SanDiskVault password

  6. Enter your password, click Login 

  7. Click NEXT on the menu that appears 

  8. The next window _should _be an exact duplicate of the file SanDisk encrypted (to save to the USB drive), except this file is NOT encrypted! You should then be able to drag and drop your files without encryption.

I think we all had SanDiskVault figured differently. It SAVES files, documents, etc., in an encrypted state, but with your password, you can go directly to the file, see it (unencrypted), and manage it as you would any other copy+paste or drag and drop.

Hope this helps!!

It is now 2019, and I’m writing this in case anyone else is still having the same problems that the OP (and I) had.

My SanDisk USB Drive is a year old and I can still see no official way of retrieving my saved files, but I have managed to retrieve my folders and files from it…in a roundabout way. 

  • I’ve discovered that when you drag a file from SanDisk into an awaiting folder on your computer, it copies over fine.
  • If you drag a folder that CONTAINS NO FOLDERS WITHIN IT, it drags and drops fine.
  • However , if you attempt to drag and drop a folder that contains at least one folder it will fail. Or at best, copy over one empty folder.

So, as I said it is a roundabout way of extracting your folders and files, but it’s better than having your files so secure that even YOU cannot retrieve them.

TIP: To drag and drop more than one file, hightlight all said files and drag them to their awaiting location. It sounds pretty obvious, but SanDisk will highlight just ONE folder the moment it loses the cursor focus. This could be so off-putting, that you may not complete the drop.