I can no longer drag and drop

I already have 5 folders of music on my Sansa Clip.

I went to drag two more folders from my Hard Drive just now and it won’t let me (I get the black “can’t copy” sign, not unlike the no smoking icon)

Obviously, I was able to do this previously. It shows as a drive in My Computer and I can see all the other folders I dragged into the player (it’s probably been six months since I dragged those over)…

I use Windows 7.

Any ideas?



Interesting, what happens if you try copy/paste.

And you’re sure you have available space?

Are you trying to copy (drag & drop) copyrighted or DRM-encrypted content like .wma audio book files?

Thank you for your responses. In answer to both of you.

  1. I have 20 Gb of available space. 6 on Internal and 14 on External. All of the files exist on the Internal memory.

  2. I am trying to load music files. Some are from Amazon and other sites and some are CD rips. All are MP3 files.

  3. When I tried copy and paste, I got this wonderful message: "The ::{20zd04FE0-2AEA-1…\ SID-{10001, (a bunch of numbers), (a bunch more numbers) }\ does not exist. The file might have been moved or deleted.

Do you want to create it?"

I hit yes, but nothing happened. When I tried to Copy/Paste again, I got the same message with a different Hex address (I’m assuming those first bunch of numbers is a Hex location) and different ‘bunch of numbers’.

This is EXTREMELY weird.

Windows is full of weirdness.   :frowning:

I sometimes have found that when weirdness occurs, it goes away with a shutdown and restart of Windows. 

nope…I actually couldn’t do this yesterday. Today was the same problem.

Should I contact Customer Support? While I appreciate your responses, you appear to be guessing as much as me.



thx…got my fingers crossed.

Here’s another guess . . . Are the folders you are attempting to transfer larger than the available space on one of the drives? In other words, you say you have 6GB available on the internal memory. Are the 2 folders you are transferring at (or over) this size?

Remember you cannot just select 20 GB worth of files and assume it will transfer what it can to one drive and then automatically switch over and transfer the rest to the other drive.

And are you using MTP or MSC mode?

Have you tried formatting the player and re-loadinig everything?

Thanks…I thought of that and tried just copying one file. Same result.

 “Are you using MTP or MSC mode?”

I have NO idea what that is. I am just dragging and dropping as if it were another drive.

“Have you tried formatting the player and re-loadinig everything?”

No…I use this when I am biking downstairs and at least I have SOME music on there. If I was to re-format and then have the same problem, I am SOL.

You would expect an error message if lack of space.

Just curious…but can you drag-and-drop (or copy)  something OFF the unit onto your computer? 

Also can you copy the music into a different folder on the computer and try drag-and-drop from there? 

You seem to be already using MSC but…

If you go to Settings/System Settings/USB you have a choice of MSC or MTP or Auto Detect. Put it on MSC, which locks it in as a basic external drive. MTP lets Windows Media Player control it and does all kinds of eccentric things. Auto may switch it to MTP if it sees Windows Media Player on your computer. 

I just got a note from the SanDisk company referring to MSC, MTP, etc.

I will try their (and your) suggestion…THANKS!

Just wondering why it isn’t mentioned in the manual. If it had, I would’ve tried it.

Btw, I could NOT move a file from the disk to my HD.

With the Clip+ in MSC mode, can you see the file on the unit, cut it but not paste it back onto the computer?  You should always be able to move a file off the unit back to your computer, as long as you can see it from the computer, so that’s just bizarre.  If you’re in MTP mode, which brings in copy-protection annoyances, that’s different. 

If using MSC mode doesn’t help, I would wonder if your cord is going bad. If you have another USB-to-miniUSB cord, like for a camera or something, try that.  

And as long as you have copies of everything elsewhere, I’d suggest formatting (through the Settings/System Settings menu), putting it in MSC and reloading. 

And you’re right–the manual does not explain at all what MSC and MTP are about, only that they are available.  SanDisk really ought to make that much clearer.  Even their knowledge base article is a bunch of jargon. 


Here, SanDisk, is the plain English that ought to be in both the manual and at the TOP of the knowledge base article. 

In MSC mode, the unit will be seen by the computer as a removable drive, enabling manual drag-and-drop, copying,  deletion and other typical file handling. 

In MTP mode, the unit can be controlled and synched through Windows Media Player 10 or above. MTP mode is necessary for DRM (digital rights management) files such as library audiobooks and music from subscription services, and allows Windows Media Player to make playlists and synch files. 

 There, SanDisk, was that so difficult? 

I’m wondering if this is a Windows thing? You know, like some sort of permissions or security setting? Is this happening on your personal computer, or possibly a work or public-use computer where transference of files to or from is prohibited in efforts to protect against viruses, trojans, etc.?

I’m using my own personal computer. I am almost scared to use a public computer…lol

I am going to try that MSC suggestion. I just haven’t had time. Maybe this weekend.

Btw, now that you’ve put it in English, my computer IS seeing it as a removable drive, so…

@leefoo wrote:

Btw, now that you’ve put it in English, _ my computer IS seeing it as a removable drive _, so…



As it should be.

It turns out I had it on “auto Detect”…I guess that switch doesn’t recognize that I am copying software…smile.

I had to manually put it in MTP mode or whichever one is the last of the 3 (not the middle one). A little confusing but all’s well that ends well.

Thank you for your help. Now I have an excuse to go back down and exercise. Not sure I want to thank you for that!!! smile