I asked this syncing question yesterday

About why it’s so slow in the syncing operation. I am watching it move through the list of songs in WMP right now and it does from 1 to 3 songs per min. Now that is just really slow. My Zune does about 20 per min. So why is it going so slow?

Maybe you have it plugged into a low-speed (USB1.1) port or hub. Try a different port, and don’t use a hub. 

I am using the same port that I use for the Zune so that can’t be the problem. And after I disconnect the cable it stays on refresh for 1 hour. Maybe it’s back to the store? What a slow machine I have bought.

Have you tried resetting it? That can solve all sorts of strange behaviors. Slide the power switch to the “on/off” position and hold it there for 20-30 seconds, then release it. The Fuze will shut off. Then turn it on again and see if the problem persists. If that doesn’t help, reinstall the firmware. Follow the directions here. Don’t use the Sansa Firmware Updater program (it won’t do anything anyway if you already have the latest firmware), do a manual install.

The Firmware updater program worked fine for me.

Also, different devices can cause different USB drivers to be loaded.  So, it may not be your Fuze - it may be (and probably is) something going on in your computer.  Can you see what it does on another computer?

If you are transferring the files in wma with copy protection enabled , the transfer will take much longer.  This is because of the embedded leaf license added to each file.  Are you transferring protected media?  If so, this is normal.


Yeeeaahh, update the firmware and a reset seemed to do the trick. It is now syncing like crazy. But the refresh thing still takes an hour. Maybe it’s a one time thing since I am loading so much right now.

The Refresh time is directly related to the amount of content on the player. If you have a ton of stuff on there it takes longer, then if you add a ton of stuff to the ton you already have… it may take a while.