How to stop podcast playback repeating itself

I go to sleep at night listening to podcasts. Usually within each podcast category I have several podcasts (established by the Album tag - e.g. This American Life). In my previous Sansa players (Fuze, Clip+, Zip) I usually played the last podcast listed in the category. The device would stop when the podcast finished playing and then turn itself off. Next day I would delete the podcast so that a fresh podcast would become the new ‘last on the list’.

Now, with the Sport, when that last podcast on the list has finished playing, it goes back and plays all the other podcasts, starting with the first one on the list. It plays all night and uses up the battery, This obviously unsatisfactory, but there’s nothing I can see that will prevent this behaviour. The Settings menu for music playback gives a repeat option that I can make sure is ‘off’, but the only thing I can change with podcasts settings is the playback speed.

Am I missing something obvious? How do I stop my podcasts from repeating?

Couldn’t you use the Sleep Timer to set it to turn off slightly after the length of the podcast?

You could treat your podcasts like music files. Just put them in the music folder.

That’s better than nothing, but it’s a PIA. Why did Sansa add a repeat function for podcasts anyway? What purpose does it serve? And adding repeating with no capability to turn it off is ridiculous.

That works, but it is a kludge at best. It’s only practical if I have nothing but podcasts on the device. Otherwise the podcast categories get mixed up among dozens of music albums.

Sansa needs to fix the issue in a firmware update.

@johnmacg wrote:

Sansa needs to fix the issue in a firmware update.



I understand your concern and issue; but I also am not optimistic about a firmware upgrade happening.   :frowning:

I really wish this problem could be fixed.  I listen to podcasts on my MP3 player to fall asleep, and while I try to remember to set the sleep timer it is a pain to do and if I wake in the night I am too groggy to remember to do it.  The player just keeps repeating the tracks and runs the battery down and I have weird sleep. 

I moved my files to music as suggested, but then my place isn’t saved in the podcasts when I shut it off during the day or I accidentally knock the player and lose my place (and forwarding is so slow…).  I know you can lock the player but I am subject to constant interruptions as I work and need to be able to turn off the player immediately, not wait as I fumble repeatedly trying to unlock the player.

So just posting in here to add my voice to those asking for a fix for this problem.

You should keep trying to use the Sleep Timer (under Settings).

I usually pick 20 or 30 mins.  The player will remember the exact moment where it turned off.

Sleep Timer seems to work for all the possible modes of play.

Best Wishes

The sleep timer is still a kludge at best. We should be able to play the last item in a folder and expect the player to stop at that point. That’s what happens in every other player I’ve used - unless I’ve specially set it up to keep looping. 

I use my Sport for Podcasts all the time and store them in the Podcast Folder. 

If I navigate to one via Folder/Internal Memory/Podcasts then it plays once and then goes into pause mode which is the behaviour I prefer.

If I navigate to the same podcast via Books/Podcasts then it repeats when it finishes.

If I have more than one Podcast in the folder then it plays them all but still pauses when it reaches the end if I use the first method of navigating to them. If I don’t want several to play consecutively them I put them in individual folders.

So I can choose how Podcasts play which all seems fine to me.

Your suggestion to use Folder Mode to avoid playback “looping” of podcasts in a subfolder is excellent !!

However, when using Folder Mode, the Clip Sport/ Clip Jam do not create a “resume” point for audio files in Podcast (or Audiobook) subfolders.

     It’s always something…

I cannot believe how thoughtless / dumb these manufacturers can be.

Having searched for a player [succesfully] which remembers where to restart it never occured to

me that I would not be able to stop it repeating.

I am so ****** off.

The other comments in this thread are spot on.

SanDisk really should fix this but I suppose we can whistle for that.

Why did they even add this bug (I refuse to call it a feature) when the zip clip didn’t have it? I had a clip zip and I loved how it worked. The only reason I replaced it was because it froze up one day and none of my attempts to reset it worked. I ended up having to settle for the clip sport, and it is somehow an inferior product to its predecessor.

I use the Sleep setting menu to resolve the problem with automatic repeating of podcasts in Books mode.

I also use the Sleep menu to save the battery when I expect to fall asleep listening to the Radio mode or Music mode.