How to repair micro sd 16gb card? It shows 31mb

Hey, have repaired your Micro SD card and also get your desired Samsung phone data back? After experiencing similar phone memory card format data loss troubles several times, I know the first thing you are supposed to do is to stop using this formatted card and then see whether the lost stuffs can be restored with card format recovery software.

Here is guide for you:

Recover photos from formatted SD card

I had a problem with a 64 GB SDXC card yesterday. It’s capacity showed as “1 MB” on all devices and showed both “NO SD” and “SD ERR” in my GoPro Hero 3+ Black (v3.0.0). I tried formatting using a computer (Win 8) with diskpart.exe as well as other reformat tools. No luck. I then plugged it back into my GoPro and tried reformatting it on there (settings>erase>erase all/format). This seemed to fix the problem and it now recognized it as a 64GB card on my devices and functions normally. 

That said, there seems to be no way to recover any data on the card. This needs to be addressed by SanDisk however I have not yet gone through the hassle of contacting them. 

This problem is when you protect you SD card with password, and try to format before without uncript using you default password, and then SD card only shows this 31mb. Maybe any software can format without decript, but how, and what program can do that?

1 Like



You can use DISKPART in Windows, or the equivalent fdisk command under Linux/Mac.

DISKPART (Windows)

Start a command prompt, and start the DISKPART console. List all of your disks by typing LIST DISK, then select the proper disk with SELECT DISK # (where # is the SD card). You can then type CLEAN to clear the partition table on the card, effectively blanking it. MAKE SURE YOU SELECTED THE PROPER DISK BEFORE RUNNING THE CLEAN COMMAND!

To create a primary partition to reuse the space on the card, type CREATE PARTITION PRIMARY. This will then reallocate the previously “cleaned” space.

To format, type FORMAT FS=FAT32 QUICK, and finally, to reassign a drive letter, type ASSIGN.

If you’re unable to determine the proper disk, remove the SD card, run DISKPART and LIST DISK, and then re-run it with the SD card inserted. The SD card is just the disk that has been added.

Note that the above commands are not case sensitive; I used caps to match the convention DISKPART displays.

FDISK / CFDISK (Linux/Mac)

In a terminal, start fdisk /dev/sdx where /dev/sdx is your SD card device (may depend on the Linux distro you’re using, see below). You can then delete all existing partitions on the device by typing d, and then adding a single new partition & format it. You an also just type n to create a new partition table, and start laying everything out.

cfdisk is also another viable tool, which is basically fdisk with a greatly improved user interface. In both cases, once the drive is formatted, you will lastly need to mount it.

If you’re unable to determine the proper device, remove the SD card, run fdisk -l, and then re-run it with the SD card inserted. The SD card is just the device that has been added.


I found a solution that worked easily for me.

My SanDisk 2Gb was offering me only 34Mb and I didn’t even formatted it.

So I tried formatting and nothing worked.

I found this How-to Geek answer and followed the steps and I recovered the whole 2Gb.

Formatted it as NTFS afterward because it is more up to date and you won’t get the “Need to format” message anymore.

At least, I didn’t get it after format.

So here is the address :

I made myself a copy of the steps in case it happen again and

I added the lines 

"Redo the List disk again and you will see an asterix aside (on the left) of the disk 1 and that tells you chose the right disk."

Right after 

Whatever commands you execute after this point will only make changes to the selected disk; now would be a good time to double check you’ve selected the right disk just to be extra safe.

Because it would be unfortunate to wipe out all my C:\ drive instead of the SD Card.

Make sure you see the little asterix aside the SD Card Disk number ID and then do a Clean command.

After, you format and there you go.


i know how fix it. 

contact me to e-mail

i can help you

contact me email

Apply the below given command line to fix this issue:


  1. Start a Command Prompt with Admin Permissions. (Start, Type “cmd”, right click on command prompt in the list of programs, and select “Run as Administrator”)
  2. Enter the command “diskpart”
  3. Enter the command “list disk”, locate the disk number for your USB Drive
  4. Enter the command “select disk X”, where X is the number of your disk from step 3.
  5. Enter the command “clean”, this will remove any and all partition or volume formatting from the disk with focus.
  6. Done, type “exit” to quit diskpart.
  7. Now in back in Disk Management, you should be able to right click the drive and choose new simple volume and proceed with formatting.

For more: How to Restore a Memory card Capacity Back to Full Size : Using Diskpart?

Yes its recoved once I formated usiing my DSLR, thats great…

gparted worked!  follow the steps per youtube.

Merhaba Papatja sitesinde belki bu soruna çözüm bulabilirsiniz Silinen fotoğrafları geri getirme ve silinen dosyaları geri getirme hatta hafıza kartı kurtarma gibi sorunlara çözüm bulabiliyorlar linki aşşağıya bıraktım buyrun bi bakın eminim işinize yarayacaktır. Silinen fotoğrafları kurtarma 

Bu konuda bir çok site var ama bu site çok güvenilir bir sitedir veri krutarma konusunda tamir de yapıyor kısa süre içinde sizlerin sorunlarını gidereceğini düşünüyorum bir göz atın isterseniz.

Merhaba arkadaşlar Papatja web belki bu soruna çözüm bulabilirsiniz Silinen fotoğrafları geri getirme ve silinen dosyaları geri getirme hatta hafıza kartı kurtarma gibi sorunlara çözüm bulabiliyorlar.  Linki aşşağıya yazdım buyrun bi bakın işinize yarayacaktır. 

Silinen dosyaları geri getirme

Bu konuda bir çok site var ama bu site çok güvenilir bir sitedir silinen veri krutarma konusunda tamir de yapıyor.  Kısa süre içinde sizlerin sorunlarını gidereceğini düşünüyorum bir göz atın isterseniz. Bu türlü sorunların çözümünü bulmak gerçekten çok zor iyi biliyorum o yüzden böyle bir  cevap yazdım sandisk hafıza kartları gerçekten çok iyi fakat yeteri kadar teknik destek yok sanırım.

Hey Guys!  I had an 8GB that only shows 1.8GB.  I had used it in a garmin GPS to update the GPS unit.  Well it went in with 8GB and came out with only 1.8GB. The garmin can only use 2GB, so it partitioned the chip for 2GB.  But I found this really brilliant video that shows how to re-partition the chip and it worked like a champ.  here is the youtube web site.

good luck, but be careful what you are working with, cuz you could mess up your main computer drive if you’re not.


I am having the same issue here with 2 Micro SD cards and the other 2 don’t show up at all in anything. 

Big ups to you bro, I created an account just to give you some kudos. I tried going through the cmd prompt and diskpart then clean then create primary partition. And none of it worked, this is brilliant, thank you!

I’m almost certain it was because of password protection, it was in my orange pi running retrorangepi but I have no other Linux devices to set up a correctly positioned drive. Dunno why Android works, but it does

who are you are you referring to for your solution?

Well it may be possible that your memory card has been corrupted and so it is showing such error. However, if it ever happens to your again do not worry because you can now easily repair corrupted memory card with the help of some effective methods. Some of the ways include:

  • Solution 1: Connect Memory Card To Another Device
  • Solution 2: Change The Card Drive Letter Name
  • Solution 3: Repair Corrupt Memory Card Using CMD Command
  • Solution 4: Format Memory Card To Fix Corruption
  • Solution 5: Use SD Card Formatter Tool To Repair/Format Corrupt Card
  • Solution 6: Reinstall The Drivers To Make Corrupted SD Card Detected
  • Solution 7: Scan SD Card With Anti-Virus Software To Fix Corruption

If all these ways or methods do not work then you can also try SD recovery tool. But, to know how you can easily perform the steps to apply the above methods, you can visit the link:

Hi all,

It looks like I’ve had the same issue as many of you, a Sandisk (in my case) SD memory card that goes from functioning perfectly, to only having a capacity of 30mb, and seen as having a RAW format. I’d taken 3 days of videos / photography on holiday, when the card seemed to be blanked and in the state above.

Reading through this thread and others, there’s lots of advice on how to format the card so that it will work again - but I think many people like me only want to restore the files, and would never want to trust even a repaired version of the card again to store anything of any value.

Fundamentally, I downloaded all the data recovery repair services (EaseUS Data Recovery, M3 Data Recovery, WonderRestore, Stellar Data Recovery etc). None of these found any data whatsoever. Partition software would not find a single partition, even on deep scan / full modes. I’ve read that partition software does not necessarily delete data, so my next step was to try to create correct partitions on the card, and hope this would allow me to scrape for some of the data with some of the above recovery apps. Next step was GParted (Mac Partition software you need to run in a VM Virtual box on Windows), as there is an account from someone that just mounting the SD card with this (without carrying out any functions brought back the data).

…I didn’t need to, repeatedly inserting and removing (without safely removing for brevity) the card eventually had all the data flash up again. I wasn’t able to copy much off it before it was derecognised and looked RAW to the PC again, but just repeatedly inserting and removing eventually brought up the system, and over a day or so, it stayed stable long enough to remove the data I needed. In total I tried inserting and reinsterting about 150 times. With breaks. It would seem to work best when it had been some time between attempts, but it may just have been random. 

So to recover data, none of the official or freeware apps did anything, but perseverence had the card show that everything was in fact intact, but for some reason was unable to be accessed. Just try mounting on different devices, repeatedly, and hopefully you will get headway somewhere. Someone above posted an external SD card mounter as solving the problem (on Amazon), maybe that worked for them for a similar reason.

Good luck but I wouldn’t waste your time on data recovery apps if it’s showing as 30mb capacity. Strangely the SD card is becoming more stable over time, from seemingly being blank blank blank, three days ago (and showing nothing dozens and dozens of times), now it seems to load 20% of the time I plug it in. 

Hope this helps some of you!