How to repair micro sd 16gb card? It shows 31mb

this worked for me. I selected the Format Size Adjustment to “on” under the Options button. the 297mb card magically had 29.7gb after formatting. pretty sure the card was linux formatted for a cyanogenmod boot drive which is why it did not show full capacity. thanks a bunch unklefunky

I have a 16 gb micro sd card that i have for my galaxy s3 but it wont format. I even tried to format in on my computer but the computer states it cant compleet the format. I have only had the SD card maybe a week.

@speck2677 wrote:

I have a 16 gb micro sd card that i have for my galaxy s3 but it wont format. I even tried to format in on my computer but the computer states it cant compleet the format. I have only had the SD card maybe a week.

Then return it as defective. :smiley:

My Sandisk 8 Gb Ultra Card Just showng its 8gb to 30mb only.

i try to format it but dont get the success. plz help to recover it.

Screen Shot Atteched

See the only solution known is the post directly above yours.

Btw . . . there is no screen shot “attached”. Not that it would help or make any difference. Return it and get another.

I got solution, but I can’t figure out why it works.

I have Scandisck Ultra 64GB microSD and becouse of W7 it format it to 1MB.


But your “broken” microSD card to Android device (tablet, phone etc) and it should say that you need to format card and when I formated it it started to work correctly. Size is now 64GB again and I’m happy.

btw. Gurus, are you using linux at all? It wasn’t so hard to just try what happens if you but it on different platforms or different OS…

1 Like

I found something really stupidly simple to use… I got an IOGEAR SD Card reader from amazon… Amazon IOGEAR MicroSD Reader Writer This into a WIndows 7 or Windows 8 machine showed all the missing data off the SanDisk Ultra 32 GB MicroSD HC I card… After the data was recovered I was able to use the SDFormatter to clear the unit completely…


I have the same problem, hence I ended up to this forum, by google. Honestly, a bit surprised. I searched for the keyword ‘8gb sdhc read as 30.6mb’, and only a few (2-3) of the hits that happened to other brands. Most of the hits are sandisk. 

Well, starting from the past, I’ve been using a sandisk compactflash (CF) for my DSLR, with zero problems. Today I bought a brand new sealed in box 8GB SDHC class 10 from a sandisk dealer, and this very same thing happened, right off the bat. That’s the difference, while this problem happened to others’ older card, it happened on my brand new card. I guess it can be considered a blessing, as I don’t have any data yet to be lost in it. 

Card reader is Transcend rdp8k, also with zero problems prior to this day. Tried in both windows 7, and XP SP3, and an old blackberry, all failed.

Tried every possible solutions I could google in the past few hours. From Formatter 4 to regedit (found a thread that suggests editing the registry to fix locked mobile drive)

I’m going to ask for a replacement tomorrow, but honestly, by what I’ve read so far around the net, I’m kinda reluctant to exchange it to another sandisk. I still believe sandisk make a helluva CF, but for SD cards… I also got a problem with a sandisk cruzer blade 16GB thumb drive, but it belong to another section of the forum of course.

Just thought I’ll post here to add 1 more voice to the ‘1%’…


This worked for me: put the micro-sd card into any Android device and use native format utility.

Hey, have repaired your Micro SD card and also get your desired Samsung phone data back? After experiencing similar phone memory card format data loss troubles several times, I know the first thing you are supposed to do is to stop using this formatted card and then see whether the lost stuffs can be restored with card format recovery software.

Here is guide for you:

Recover photos from formatted SD card

I had a problem with a 64 GB SDXC card yesterday. It’s capacity showed as “1 MB” on all devices and showed both “NO SD” and “SD ERR” in my GoPro Hero 3+ Black (v3.0.0). I tried formatting using a computer (Win 8) with diskpart.exe as well as other reformat tools. No luck. I then plugged it back into my GoPro and tried reformatting it on there (settings>erase>erase all/format). This seemed to fix the problem and it now recognized it as a 64GB card on my devices and functions normally. 

That said, there seems to be no way to recover any data on the card. This needs to be addressed by SanDisk however I have not yet gone through the hassle of contacting them. 

This problem is when you protect you SD card with password, and try to format before without uncript using you default password, and then SD card only shows this 31mb. Maybe any software can format without decript, but how, and what program can do that?

1 Like



You can use DISKPART in Windows, or the equivalent fdisk command under Linux/Mac.

DISKPART (Windows)

Start a command prompt, and start the DISKPART console. List all of your disks by typing LIST DISK, then select the proper disk with SELECT DISK # (where # is the SD card). You can then type CLEAN to clear the partition table on the card, effectively blanking it. MAKE SURE YOU SELECTED THE PROPER DISK BEFORE RUNNING THE CLEAN COMMAND!

To create a primary partition to reuse the space on the card, type CREATE PARTITION PRIMARY. This will then reallocate the previously “cleaned” space.

To format, type FORMAT FS=FAT32 QUICK, and finally, to reassign a drive letter, type ASSIGN.

If you’re unable to determine the proper disk, remove the SD card, run DISKPART and LIST DISK, and then re-run it with the SD card inserted. The SD card is just the disk that has been added.

Note that the above commands are not case sensitive; I used caps to match the convention DISKPART displays.

FDISK / CFDISK (Linux/Mac)

In a terminal, start fdisk /dev/sdx where /dev/sdx is your SD card device (may depend on the Linux distro you’re using, see below). You can then delete all existing partitions on the device by typing d, and then adding a single new partition & format it. You an also just type n to create a new partition table, and start laying everything out.

cfdisk is also another viable tool, which is basically fdisk with a greatly improved user interface. In both cases, once the drive is formatted, you will lastly need to mount it.

If you’re unable to determine the proper device, remove the SD card, run fdisk -l, and then re-run it with the SD card inserted. The SD card is just the device that has been added.


I found a solution that worked easily for me.

My SanDisk 2Gb was offering me only 34Mb and I didn’t even formatted it.

So I tried formatting and nothing worked.

I found this How-to Geek answer and followed the steps and I recovered the whole 2Gb.

Formatted it as NTFS afterward because it is more up to date and you won’t get the “Need to format” message anymore.

At least, I didn’t get it after format.

So here is the address :

I made myself a copy of the steps in case it happen again and

I added the lines 

"Redo the List disk again and you will see an asterix aside (on the left) of the disk 1 and that tells you chose the right disk."

Right after 

Whatever commands you execute after this point will only make changes to the selected disk; now would be a good time to double check you’ve selected the right disk just to be extra safe.

Because it would be unfortunate to wipe out all my C:\ drive instead of the SD Card.

Make sure you see the little asterix aside the SD Card Disk number ID and then do a Clean command.

After, you format and there you go.


i know how fix it. 

contact me to e-mail

i can help you

contact me email

Apply the below given command line to fix this issue:


  1. Start a Command Prompt with Admin Permissions. (Start, Type “cmd”, right click on command prompt in the list of programs, and select “Run as Administrator”)
  2. Enter the command “diskpart”
  3. Enter the command “list disk”, locate the disk number for your USB Drive
  4. Enter the command “select disk X”, where X is the number of your disk from step 3.
  5. Enter the command “clean”, this will remove any and all partition or volume formatting from the disk with focus.
  6. Done, type “exit” to quit diskpart.
  7. Now in back in Disk Management, you should be able to right click the drive and choose new simple volume and proceed with formatting.

For more: How to Restore a Memory card Capacity Back to Full Size : Using Diskpart?

Yes its recoved once I formated usiing my DSLR, thats great…

gparted worked!  follow the steps per youtube.