Same here,. i’ll guess i wont return it, glad i bought two on black friday.  will wait for a solution,. 

Use GPARTED in Linux. Delete the partition table and then format it using whichever filesystem you prefer. Linux gives no craps.

After following the whole process, I have not seen StorageDevicePolicies after “Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control”  so, what should I do to format my 8 GB SanDisk Pen Drive?

Here is how to Remove The Write Protection From A USB Drive

1- Press the WIN+R keys together to launch the Run dialog box. When it opens up, type in regedit and hit the enter key.

2- As next, you need to navigate to the following path as shown in the screenshot given below:

HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> Control

3- Now, under the Control key, you need to look for a key named StorageDevicePolicies.

If there is one already, you can go straight away to step 5.

Else, right click on the key Control, click on New and then on Key.

4- Name the newly created key as StorageDevicePolicies.

5- Click on the newly created StorageDevicePolicies key in the left window pane, and in the right window pane, you need to create a new 32-bit DWORD value. For that, right click anywhere on an empty space in the right window pane, click on New, and then on DWORD (32-bit) value.

6- Give the newly created DWORD value the name WriteProtect and double click on it to edit its value data. To disable the write protection from the USB drive, set the value in the Value data field to 0.


First Solution: Sometimes virus infection corrupt USB flash drive and makes them locked and write protected.

So, it is suggested that you must first scan your USB flash drive for virus.

Second Solution: Some USB flash drives come with mechanical switch on them that put them into Write Protected mode.

There can be very small slider switch. And if this is the case, then you must move the switch to unlock position.

The above solution is brought to you by:

if you will still face this problem try this video method to solve your problem

I’ve since set my computer to automatically pull DNS from the router. I changed the router to use OpenDNS, and no longer pull the Charter DNS info automatically. All systems on the network will now use OpenDNS servers.until i saw ShowBoxLucky Patcher Kodi

I had just such a USB hard disk which had been formatted as NTFS and used as a Windows 8 ToGo! boot disk. I could not copy any files to it or format it under Windows 7 or wipe it using RMPrepUSB - every time I tried I got a ‘Write-Protect’ error.

To format pen drive it is must to remove write protection. There are various ways to remove write protection from pen drive but i am going to tell a way by using command prompt. I am leaving a link here, it will defintely help you to remove write protection.

hi man 

i had the same probleme 

and this worked with me 

just install the reg file to disable write protect

good luck

Please read this article and get your perfect solution or remove write protection from your USB drive windows. I also use these methods it is very helpful for me. To go this link click here:

Please read this article and get your perfect solution or remove write protection from your USB drive windows. I also use these methods it is very helpful for me. To go this link click here:



I read and tried most of this forum…it didn’t help. My USB is SanDisk 64 GB Ultra Fit bought this year, looks qute nice with metal casing, now after 4-5 mounts I can’t format, write or create files. Neither with Window or Linux. Totally useless…

Registry change does not help. Windows Device Mnager, HP USB Stirage and similar tools all returns “Write Protected” errors…

Yup.  Return it to the seller or to SanDisk itself.

Very interesting topic. I recently bought a pen drive and i didn’t know that it was write protected. Now i made it write unprotected. I am going to save this webpage by using shortcut key "ctrl+s". I think this page will help me in future.

Do you actually represent Sandisk Ed_P?

If so i want to feed back some information to the decision makers within your organisation.  Given the current GDPR rules and regulations, do you deem it acceptable to be asking people to send their protected data to a company not knowing how that data will be disposed of.  Frankly, it is the most absurd scenario that i have come across for quite some time.  I have sensitive data secured on my faulty USB and you want me to send that sensitive data for what reason exactly?

I would strongly suggest that you take the time to provide a tool to dispose of the data upon customers USB’s as they are clearly unusable in their current defective state.  Quite frankly i will not bother buying from Sandisk ever again until you sort this mess out with your clearly poor sub-standard product.


No FopaUK I do not represent SanDisk in a professional capacity, I’m just a user, like you.

2 points you should consider:  If a USB drive should fail:

  1. Would you prefer it preventing you from accessing the drive in any fashion.


  1. Allow you to access, read, copy your files but prevent updating the files on the drive?

Ideally having neither problem is preferable.

So you have secure encrypted files on the drive and you can’t update them.  And since they are encrypted nobody else can update, or view, them either, only you can.

Now if the drive is important and you need a replacement would you prefer a free one or to just buy a new one?  If you want the free one, return the damaged one to SanDisk and they will send you a free new one.

Concerned about the unencrypted files being seen?  Porn can be embarassing.  Then inform SanDisk when completing the RMA form of your concerns and they may allow you to destroy the drive with a hammer before returning it.  They have done that before.



it seems I have the same issue. I’m, getting it’s case for RMA but since two it’s predecessors from different manufacturer died exactly the same way I just want to make sure that it’s not fault of my laptop USB slots or specific usage causing the drives defective but always the drive self.

I’m using also older pendrives of smaller capacity but never had this problem with them.

If the problem has happened before and with different brand drives even it sure sounds like the problem is your system.  Not necessarily your machine entirely at fault.  The problem could be tied to heat, power surges, low power due to competing USB connections.  Or malware.