can any one please suggest that why it is displaying such error…

It’s broken.

"can any help me to resolve this issue???"

Yes, return it.

""Have you read any of the previous replies in this thread? :confounded:"

Obviously not.  :cry:


If you have windows…

run (just do a search for it it will be there)

In the old school command line box that no one seams to care about anymore type

chkdsk e: /F /X

where e: is the drive letter assigned to your usb stick.

Wait for a few minuites at most and you will probably have a perfectly writeable usb stick even if no errors were found.

Worth a try to saves days of waiting for a replacement in the mail or a trip into town.

my scandisk usb 16gm i can open or save any file from that usb please help me a simple solution for open it


@khalidanani wrote:


Option #1

Option #2

Option #3

I bought new sandisk 16gb usb pendrive in that i cant able to save the files nor i cant format because it is showing write protection and i tried to remove that but it is not happending. Please suggest me how to do that

i tried to remove that but it is not happending. Please suggest me how to do that

Read some of the postings in this link for solutions.

you  can find step guide here

I have a SanDisk Cruzer Glide 128g and it is telling me that it is Write Protected, I did not place any write protection on the flash drive but it is there and now I cannot write anything to the drive. My first question is, how do I remove the write protect? And secondly, why is SanDisk putting drives on the market with potential problems for us consumers? Finally, the fix or repair should come from the company (SanDisk) not from us users who are experiencing the same problem. Where is SanDisk responsibility with this issue? Thanks and have a good day.


there is no fix. If it is showing write protected the drive locked it that way to prevent any possible data loss. Back up the data and contact sandisk support for a warranty replacement. if you have sensitive data on the drive let them know. they have a return process for that as well. 

Hi I did it. but it doesn’t work  (CHKDSK Command)

it says:  Windows cannot run disk checking on this volume because it is write protected.

don’t try it…wasting time

Wow. thank you so much. it works :smiley: 

well if you guys having problem with finding ‘Storage device policy’

then go to the same path :-

Navigate to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control

then simply press Ctrl+f 

And type “StorageDevicePolicies” or “Storage Policies” any one that you like. it will take a little time 

and eventually it will  stop with highlited  text without thinking hit Delete or Press right click and choose delete and then 

try following

Step 2:

insert the USB device, then

control panel->Admin Tools->Disk Management

Your boot drive will show as C:\ and under 
Layout will be  Partition
File System will show  NTFS

How does your USB show up?

Step 3:

So if you go to  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
look for  StorageDevicePolicies  – if found, open it and look for  WriteProtect  - - delete the key

Step 4:

Try this …it definitely works…I found it after lot of research online…

i m really happy that i got my pendrive back. in working condition.:laughing:

I am also having the same promblem, can someone please help :confused:

@themultigamer4 wrote:

I am also having the same promblem, can someone please help :confused:

Read this and follow the advice.


If you cannot copy, delete or send data from your pen drive or face problem when you format it. It shows en error message like “The disk is write protected. Remove the write protection or use another disk.” 

Basically write protection allows a pen drive to keep its content from being changed.

Number of Methods to fix write protection error on pen drive

Best ways to remove write protection error from your pen drive goes here:

Fix Error through Registry Editor

  • Go to “start” option of your computer and open Registry editor
  • For this you write a command “regedit” on run
  • When registry editor open, navigate the location: HKEY_LOCAL_MACHINE/System/CurrentControlSet/Control/StorageDevicePolicies
  • In right side you will get a value named “WriteProtect“. Just right click and change the hexadecimal value from 1 to 0 and you got it. You have safely remove the write protection error.
  • Exit registry and restart your Operating System
  • Then connect your USB on PC

Note: If the value named “WriteProtect“ does not exist then follow same steps which is mentioned above , but change “HKEY_LOCAL_MACHINE” with “HKEY_CURRENT_USER“.

Here are few links where you can get the problem refer and fix your issue

Please follow the directions and you can remove it. REMOVE WRITE PROTECTION 

try this command ” diskpart “ don’t think CMD is difficult and it not familiar us, our guide line is a clear and step by step
source -

I was with the same issues and I managed to fix it by converting disk from MBR to GPT layout

you can use MiniTool Partition Wizard ( ), I’ve done it using DISKPART windows utility. You can convert it back to MBR if you want.

FYI, backup everything, you will have to delete all the data from the flash drive

You do realize fabioveta that converting the disk layout requires the drive to be writable.  And since we are talking about drives that are Write Protected that means your app won’t work.  Which kinda implies your posting is basic SPAM doesn’t it?

You can try to flash your chipset by following the steps in this tutorial on How to fix a write protected USB thumb drive