How to enable MTP mode in Linux [was SOLVED, solution no longer works]]

Originally in this post I asked how I could get MTP mode on my Clip+ to work with LInux – but now I’ve discovered how, thanks to this post:  If you just set the Clip’s USB mode to MTP and plug it in, you’ll see three folders, one of which is “MTP Device” – and that folder is empty.  In MSC mode, the Playlists folder is invisible and inaccessible, so you have to jump through hoops to install a playlist.  But if you create (as root) the file /etc/modprobe.d/usb-blacklist.conf (the name doesn’t really matter, only the location) and set it to this:

options usb-storage quirks=0781:74d0:i

you’ll discover that when you plug in your Clip, the MTP Device folder has magically gained some contents in the form of a store_00010001 folder, and within that folder are subfolders including Music and Playlists.

The problem is that the USB autodetector, whatever it is, grabs the device before mtplib can.  This disables the device as a USB device, enabling mtplib to operate on it. 

Populating the Playlists folder is a different task and one I haven’t figured out yet.  But this is a very useful first step.

The previous solution I posted here is unfortunately undone by a reformat of the Clip’s storage.  But I located another solution:

sudo mkdir -m 0777 /media/clip sudo mtpfs -o allow\_other /media/clip ls /media/clip # verify it worked

This sequence is a little more delicate than it might appear; when I did “sudo su” and did the mtpfs call from there, things didn’t work and I got a puzzling message “Transport endpoint is not connected”.  The webpage where I found this also cautions against removing the Clip without unmounting /media/clip.

The solution I posted earlier doesn’t seem to work in Natty.  I can mount the device but the ls operation encounters the Transport error.