How often can one try to reboot before declaring E270 is dead?

Hi I have experienced a similar start up problem on my 6GB e270 SanDisk from the woot.

It was fine last week but after transferring the songs from my workstation Windows 7,  I shut it down and went home.  I started to open the e270 and got caught in a loop of seeing SanDisk logo against the black background, then white board, before repeating itself.

Did the obligatory pressing the power/menu button, same result.

Did the left Record button +  Power/Menu button…turned it off.

Tried to connect the bugger to my computers at home and at work, and the computers don’t recognize the USB connection at all.

There is no sign of communciation between the e270 and any computer.

Help…or tell me, is it really “dead”?


Try squeezing the back a little. I’ve heard that the memory chips can come loose on the old e200s (and the e270 was discontinued years before the rest of the e200 models so yours is very old). Apparently if you squeeze it (or open it up) you can just push the memory chip back into the slot.

1 Like

Thanks for replying.  Apparently, the device is still firm, nothing is loose.  I squeezed the back but saw no change.   But if I were to open it up, what would I be looking for and what should I do?

Check out this post regarding the daughterboard saratoga was referring to.