How do you tag mp3z so nested folder names display correctly?

For radio shows I record on my computer and transfer to the Clip+, I have a main folder for each show, with each day’s program in another folder under that.  For example, “Computer\Sansa Clip+ 4GB\Internal Memory\Podcasts\Howard Stern\2011-04-14” would contain the mp3 files for today’s Howard Stern Show.  However, on the Clip+ display, this shows as “Music\Folders\MTP\Podcasts\New Folder\2011-04-14”.

Each mp3 file is tagged with a track number, Album Artist, Title, and Album tag.  The Album Artist is “Howard Stern”, the Title is “Part #”, with “#” replaced by the appropriate number, and the Album is the date, “2011-04-14”.  What tag do I need to set to get the parent folder to show the correct name, “Howard Stern”?

You might try setting your Clip’s USB mode, under its settings, to MSC (rather than Auto or MTP).  This often can fix matters like this.

Note:  if you use DRM’ed files, you need to use MTP mode.

Make “Howard Stern” the Artist. The player does not read the Album Artist field of the tag.