How can i update c140 firmware???

Hi guys can anyone help me with updating c140 firmware?
What i need to do?
Thx in advance

you dont, there is no firmware update.

Well, there is one, but it doesnt improve any features. It can help unfreeze a player thats frozen on the sansa logo.

Message Edited by Enigma on 01-31-2008 12:22 PM

So how do we get this mystery firmware update?

My father-in-law has a c140 and it is stuck on the SanDisk splash screen.  I have tried all of the suggestions in the forums (remove battery, hold menu/select button while connecting to PC, etc).  The c140 does not get past the logo screen and is not recognized by the PC.  Holding the select button (battery removed) while plugging in to the PC does bring up Windows new hardware detected wizard, but I cannot find specific drivers for this device (and I doubt that would actually fix the c140 since it is the c140 that is stuck not the PC drivers).  However it would be nice to at least get the device recognized so I could try to reformat.

So please let us know how to get the firmware update and how it can be installed to help unfreeze the player.


how about calling SanDisk? 866.SanDisk. Explain what your going through and see what happens.

Hy all!

I have a c140 too. I had the same problem, but I tried to fix it. In my case the menu appeared, but I couldnn’t see the menutexts.

I navigated the menu without the menutexts to USB and tried to switch MSC. After, I formatted the device… Late, appeared the language selection menu, and I can see the menu correctly.

I hope, I could help 

I was told I also need to update my firmware. My problem is that the general volume on my c140 is way too low. And the funny thing is that I don’t have a “Volume” option in my Menu->Settings. Sandisk support have promised to email me an updater file since it’s not present anywhere online. But do you think this would indeed bring the “Volume” option into the menu? And another question: does updating the firmware erases all the music tracks uploaded into the player?


My sandisk sansa C150 freezed @ sandisk logo. As you said there is a firmware that unfreezes a player at this instance.

Could you please point me to this firmware location?

Thanks in advance.


hi could u please tell me if its possible to unfreez the c140  as it has freezed on logo.  Has the last firmware information for the e100 series.

Also, for documentation goto

These are not easily found as the website is not well designed to navigate to support for legacy products.

The firmware flash can be found on the c140/c150 webpage on   At the bottom of the page is a link to a .rar file that you will need to download and find a program to uncomress it.