help with sansa 2G player with adding files to player's memory on Ubuntu

any guru’s out there not tired of dealing with this to help a newbie out with this. i have a personal friend looking at it as well, but your help would be aprreciated.


My problem is that linux gives me a mounting error with a “camera”, plus when i add music to my player’s memory under the “music” folder the player wont play it, for it doesn’t even say i added anything. the file add then can be taken off the player but i would like to add music to the player’s memory, and just not my 1G micro SD card. soplease if you can help me out that be great. if you need to speak in linux computer “lingo” go on ahead i’ll have my friend read it to make sence of it. thanx again Gurus :smiley:

The easiest way of using the Fuze with any Linux distro is to always use the MSC USB connection mode - this allows easy copy and paste to the folders on the Fuze by any file manager. This is not the default setting the Fuze is sold. So you might need to adjust your Fuze’s settings first. It works out of the box with any recent distro (even with my Debian Lenny system).

Please search and read this forum! There are a couple of threads about the use and setup of more advanced things like MTP mode (which you probably don’t need) on Ubuntu.

For me it took some extra effort to get MTP up and running on Debian Lenny. It works, but I only used it for one single thing: backup of the pre-loaded files from the Fuze.