Help with player that will not turn on after use in car usb port

I hope that someone on the forum can help.  Yesterday afternoon we tried plugging my dd’s clip in to the aux usb port in our Toyota van.  The system could not recognize any files - expected.  The player was fine.  We tried doing it about an hour or so later.  It still didn’t work so we unplugged it.  Dead.  It now will not turn on.  We have tried restoring it by holding down the center button etc. (we have done this in the past with great results) but nada.  We thought it might be batteries and plugged it in to be charged in our usual spot.  Nothing.  It does not turn on and the computer does not “see” it.    It is a mystery and my 17 yold is understandable upset. Any ideas on what to do?  Has anyone else had something similar occur?


Did you hold the center button down for 30 seconds (or more)?  Sometimes that’ll do it.

Sometimes also working (although I’m not sure if this’ll apply to the situation here):  leave the player plugged in to a live power source at least overnight or longer–sometimes this will trickle-charge the player into starting up again.  

To reset the player, press and hold down the POWER button for 20-30 seconds, _ not _ the Center button (the center button does nothing if the player isn’t on or if it’s frozen), Release, then press again momentarily and it should spring back to life none the worse for wear. :wink:

Oops, sorry–that’s what I meant–the Power button.  A bit of a brain freeze here . . . .:slight_smile: