Help with e260

I must have done something, but my old Sansa went from displaying in English to what appears to be a Slavic language.  I have tried everything but no cigar.  Also, it seems to only go to FM radio or Foto.  Thanks for any help!

Well, if you can get to the Settings Menu, here’s the steps to change it.

e200 :

  1. Select Settings (image of an equalizer).
  2. Language is the 5th option after Settings.
  3. English is the 1st (top) choice.