Help! The music folder is missing

this week, it starts up with a red box saying something like there is not enough space(90mb) to create database although I did not recently add or delete any song from it.

I then connected the sansa fuze to my computer and wanted to remove some songs. The fuze is recognised by the computer and it appears under “my computer” as usual. When I opened it, all folders ,including the “music” folder, were missing. I was not able to remove songs to make that 90mb available. But there are 5 files with extension “.sys” in the sansa fuze when I opened it. 

I am now stuck and have no idea how could I get the music folder back and turn on my sansa fuze again.

Does anyone know what happening to it?? Please help :cry:

For 90MB error, it’s probably not about space on the disk. There’s a bad file in there.

Take out the microSD card and see if the error goes away. If so, use something else (phone, camera, reader) to read the microSD and take out some of your most recently added files.

The bad file may also be in the internal memory. See if you can fix it with Windows. Turn the unit OFF, slide the power switch down to click into Hold position. Connect the USB end of the cord to your computer. Open Windows Explorer (computer or My Computer). Hold down the << side of the wheel on the Fuze. Connect, and you should see two drives.

Right-click on the one that says Sansa Fuze. Go to Properties/Tools/Error-Checking and check it. Don’t save bad chains or anything else it asks you to save.

If that works, then turn on the Fuze and  go to Settings/System Settings/USB mode and try both modes, MSC and MTP. Your computer can only see one at a time, so your music should be there in the other mode.

If that doesn’t work, the file is so bad you have to nuke the Fuze–losing all the files you have added by Formatting the Fuze.

thanks for helping but that method does not work for me.

there are actually other symtoms before this happens, I dont know if this help.

A few weeks ago, my fuze started to freeze on the welcome screen from time to time when I turned it on. After I removed the micro sd card from it, it works fine after renewing the database. Then I turn it off and insert the card again. Its ok after renewing the database again. When I connect the fuze to my laptop, it sometimes cannot detect the micro sd card neither. So I once thought it is contact problem.

Now, when I connect my fuze to my laptop, it recognise the micro sd every time and it does not have the previous problem.
However, the internal memory itself has the problem mentioned before.

I really dont know whats happening… Do you have any idea on how to solve this??

It makes no sense, but I have had your microSD problem a few times. What solves it is taking the microSD out and Formatting the internal memory (to FAT32). That will erase all the music on there, so make sure you have other copies. With use there must be a lot of little junk fragments floating around in the memory, which somehow interfere with reading the microSD.

To find Music, change the USB mode. Settings/System Settings/USB Mode. Try MSC and try MTP.

Your computer can only see one mode at a time.

Auto Detect choses MTP if your computer has Windows Media Player 10 or above installed, MSC if not. So if you are connecting the Fuze to various computers, Auto Detect is going to mess things up.

Also, the Music folder may be hidden from your Windows installation. You need Windows to Show Hidden Files and Folders. How you get there depends on which version of Windows you have–check your help files for “Show hidden files.”

ya, it makes no sense! thats why i cant figure out whats wrong with it

All I know is just that it is not recognised as “sansa fuze” under computer(or my computer) but just as a drive(eg. G:\ ) 
I think I am gonna format it

but I am quite sure its not about hidden folders or files because I have tried this.
anyway, thanks:smiley:

If your computer is recongizing the Fuze as a drive, that means you are in MSC (Mass Strage Class) mode. If it recongizes it as a “portable device”, then you are in MTP (Media Transfer Protocol).

In MSC mode, your Fuze emulates a flash drive, just like you say it’s doing. In MTP mode, it uses a system intended for MP3 players, cameras, phones, ect.If you put files on your computer in MTP mode, you will not be able to “see” these files unless you are in MTP mode. The same applies to MSC mode.