Having troubles (massive troubles) with my device ... not turning on and comp cant find device

Well my fm radio wasnt working well so hard reset my device.  When i truned it on the screen just popped up with sandisk then immeiately turned off. It will do this everytime… so i followed some of the things on this forum. I went to my computer formatted the removable disk F successfully and now my comp doesnt even find the sansa.  I even installed the driver and put all the files, that were originnally on it, on the device manually.  Not only am i having this problem but there isnt even a light when i plug it in now… and i tried holding the (-) and putting it in and that doesnt work i even tried hard resetting it and turning it on and it doesnt even turn on now… also it is fully charged.

Help me please 

Also it is the Sansa Express 1gb portable device  USB Mp3 player its the one with the square button pad on the right and the screen in the middle.

I have sometimes been lucky plugging the Express into a computer that has never seen it before.  

That gets a clean install of the drivers, which can be the problem.

No guarantee, of course, but it’s cheap to try plugging it into a different computer.

@gigglesryan wrote:

Well my fm radio wasnt working well so hard reset my device.  When i truned it on the screen just popped up with sandisk then immeiately turned off. It will do this everytime… so i followed some of the things on this forum. I went to my computer formatted the removable disk F successfully and now my comp doesnt even find the sansa.  I even installed the driver and put all the files, that were originnally on it, on the device manually.  Not only am i having this problem but there isnt even a light when i plug it in now… and i tried holding the (-) and putting it in and that doesnt work i even tried hard resetting it and turning it on and it doesnt even turn on now… also it is fully charged.

 

Help me please 

 

Try inserting a micro SD card and then turning on the Express again.