Griffin PowerDock anybody?

Anybody use the Griffin PowerDock with their Fuze?  I get a “device not recognized” error when plugging my Fuze into the dock.  Have tried other USB cables and other ports.  Shows up as an “unknown device” in Device Manager, with a device ID of


Thanks in advance.

Hy!! I have a problem…




• Max volume level is lowered in Normal volume setting to comply with new European Union requirement



**Where can i turn off this setting? I have a  **Sennheiser CX 550 Style II and  now the voume is bad:-( The fuse good; because the sound is good; strong; and full… And now? nothing… nothing strong, full voulme; where is the  power of music? If abide this volume; the fuse not will the best mp4 player like apple nanoch…


I think you may have hit “reply” instead of “new message” … :wink:

Message Edited by PromisedPlanet on 01-25-2010 01:48 PM

what is the model number of the griffin power dock? 

drlucky wrote:
what is the model number of the griffin power dock? 

Strangely enough, there isn’t a model number printed on it.  It has the date 2006, and “Model: Powerdock for Sansa”.

can you find a link to it anywhere?

Lotsa places … it’s being sold at, etc.  Here’s the link at the manufacturer’s site:

Here’s the manual:

I’m baffled as to what I’m doing wrong, here.  It doesn’t work with my Sansa e200, either.  I can plug either player into the same USB port with the standard Sansa cable, and they work fine.  With the dock, Device Manager shows an “unknown device” with USB device instance ID “USB\VID_0000&PID_0000\5&28C0DE0&0&1”.  Vendor and product IDs equal zero, looks ominous.

if you ahve 2 devices with the same problem in the dock and both work when connected without the dock you may just have a bad dock.

I considered that, though after doing some more Googling, I see people talking about weird behavior with this dock when connected to hubs, without hubs etc.  But I’ve tried every permutation I can think of, so you’re probably right.  Makes a good charging station, anyway.  :neutral_face:

Try seeing if you can access the Sansa when docked.  Does the Sansa (are you docking your Connect, or a Fuze?) display “connected” when in the dock?  I’ll bet that a data connection (pin) is loose internally.  The Griffin dock only has a few SMD components on the internal board,  the Mini-B connection, and a buffered audio jack.

Bob  :smileyvery-happy:

Neutron Bob;

I’ve tried both a Fuze, an e200 with Sansa Firmware, and the e200 Rockboxed.  They all indicate that they are connected (data) to the PC.

The PC shows a communications problem with all of them?  Can you access the device using Exploder?  The “connected” icon shows that the Sansa sees something on the data lines, I wonder if it’s just one of the two lines, or a signal level drop on one or both of them, enough to “irritate” the PC’s USB bus.

Bob  :neutral_face:

Message Edited by neutron_bob on 01-26-2010 07:34 AM

Yes, I get the same “USB device not recognized” when any of them are plugged into the dock.  While in the dock, the device is not accessible via the PC … it doesn’t show up as a removable disk in MSC mode, and doesn’t show up as a portable media player in MTP mode.  Device Manager shows “unknown device”.

If I had that Griffin here on the bench, I’d bet we would find a damaged circuit.

Bob  :smiley: 

neutron_bob wrote:

If I had that Griffin here on the bench, I’d bet we would find a damaged circuit.


Bob  :smiley: 

Yep, appears that way.  Now check this out … yesterday I exchanged a series of emails with Griffin tech support, and after coming to the same conclusion, they’re sending me a replacement.  In spite of the fact that I no longer had the receipt or any other proof-of-purchase.  I just had to send them a digital picture of my existing dock, destroyed.

That’s customer service!