Google Chrome Profile Version Error. Error message

Google Chrome Profile Version Error. Error message Does anyone know why am I receiving these profile errors again and again from Chrome? I had installed an update on my recent Chrome. After updating, it didn’t work. So I installed the previous version of Google Chrome. Now, I am continuously receiving this profile error message: 

Your profile can not be used because it is from a newer version of Google Chrome. Some features may be unavailable. Please specify a different profile directory or use a newer version of Chrome. I haven’t installed any corrupt version. I have just installed the version which is a bit older then. Why does it say that the profile is from a newer version. Why this version doesn’t support the profile of a latest version? I want some perfect answers and a quick solution on how to end this error message. If anyone has any idea regarding this, please tell me. As I have been through this situation for 14 days and can’t bear it anymore.