Ghost Files/Navigation Issue

I tried researching this before posting, but found that my issue is a bit different than others who have had similar problems.  I have my Fuze full of Rhapsody files, all of which were playing just dandy and showed to have another ten days of play before they needed to be updated.  The other day, I was listening to my Fuze.  I turned it off for a few minutes.  When I turned it back on, I received the message that it was updating my music although I hadn’t gone anywhere near a computer.  When I went to “play all” it said there was no song.  I quickly realized that all directories (artists, tracks etc) show <empty>.  My photos are gone as well.  And yet, the player still shows that 5.1 gigs of memory are used, so all the files are clearly still there.  I’m guessing the directory tree is gone somehow.  I’ve tried to think how to restore it on my own, but I’m at a loss.  I tried connecting to my computer and Rhapsody again, to see if Rhapsody would find the files and update them.  Now Rhapsody can’t find anything either.  Windows Vista also can’t find the files, although it too recognizes that the space is used.  

It isn’t like this is a player that’s seen a lot of use.  It is nearly new.   It took me hours to install 800+ songs and I’m reluctant to try reformatting the thing and starting over, especially if this whole fiasco is likely to happen all over again after another fifty hours of use (about all this player has seen since I got it).  I’m really hoping someone can suggest a fix.  Thanks for taking the time to read

Put it in MSC mode, connect, and delete mtable.sys. That’s the database listing. It should reconstruct a correct one when it reboots.

Thank you for your help!  

I tried this and it did not work.  However, perhaps I didn’t follow your instructions correctly?  I will tell you what I did, in case I misunderstood something.  

I checked to make sure the player was in MSC Mode.  It was.  I then connected it to my Vista Laptop.  I went to “My Computer” and clicked on Drive F, the player.  I located mtable.sys and deleted it.  It showed to be gone.  I then disconnected my player from the computer.  It showed to be “refreshing my media” before it would turn off.  It then turned off and let it sit for about three minutes.  When I turned it back on, it still showed <empty>.  I reconnected it to my computer and checked it.  mtable.sys had indeed been replaced, as you indicated it would be.  Yet, sadly, it still showed to have no files, only used space.  I repeated this process a couple more times, as well as rebooted the computer itself, since that seems to be the cure-all when everything else fails.  Still no luck.  

Did I follow your instructions correctly, or did I miss something?  

Message Edited by TomJensen on 05-03-2010 06:19 PM

I don’t think I can blame this on Rhapsody, unfortunately, because my photos that I had on the device disappeared as well.