FW v01.02.17A Corrupting Files ("stuttering" when played)

Bought Clip+ (4GB) May 2014 and had no problems until two weeks ago when podcasts started “stuttering,” i.e., repeating or skippipng words; however, music files still played fine. Thought it was a problem with the podcasts’ site, so didn’t worry about it.

Yesterday, tried to download updated podcasts and same thing happened.

Upgraded FW to v01.02.17A. Problems persist.

Reformatted (System Settings). Problem persist.

Because I had to lose all of my files to reformat, I uploaded music and podcast files back onto the device and now music files have the same problem as the podcasts.

I tried Rockbox for an older FW version; however, with the v01.02.17A FW, Rockbox can’t find the mounting port. My friend’s research says this is a problem with Sansa’s FW, not Rockbox. 

I have written to <support@sandisk.com> but I’m not sure if that will help, especially since I am almost at the one-year mark when the warranty expires.

Has anyone had this problem? Any solutions or do I need to buy another player? If I have to purchase a new player, don’t I risk the same FW problems?


Call I-866-SANDISK and ask about a warranty replacement before your year is up.

They may walk you through the steps you’ve already taken–reinstalling firmware and reformatting–because that’s pretty much all you can do to fix a software problem.

And now that I think of it, what the heck is 1.02.17A?  The firmwares are usually just version numbers, no concluding letter A. (Though there used to be letter suffixes for different regions, I guess.) 

The latest firmware is 1.02.18, as of 2012. If you’ve been using the Updater to update, don’t bother, and uninstall it from your computer because it’s a waste of time at each reboot.

Just get the firmware file and install it manually.


Download the zip file, unzip it, drag the contents of the folder onto the driveletter of the Clip, disconnect and it will install.

“Skipping” is sometimes the result of what’s actually a failing headphone jack or failure to push the plug all the way in, but that would just give you dropouts. Repeating words? That’s bizarre. So it could be a hardware problem.

No, you shouldn’t have the problem with a different unit. Many, many people use the current firmware.

If you want to experiment a little more before getting a replacement, you could also try an older firmware. Just copy and paste the link above into your browser and change to a lower number, like this:


For what it’s worth, I plugged 1.02.17.zip and 1.02.17a.zip into that formula and neither one came up. 1.02.16 and 1.02.15 both do exist.

Are you sure you got the firmware from the SanDisk site?

For the moment I’d leave Rockbox out of it. Get it running with SanDIsk firmware or get it replaced before you’re out of warranty.

1 Like