Fuze won't finish playing song

So I dunked my old Fuze in my hot tub for a second.    It wasn’t on-- so I just shook it off well & set it on the TV for a few days.

When I charged it up and turned it on, it worked fine. . .  except that it only plays 44 seconds of a song, then it starts it over again.

I’ve tried just listening to it for a while to see if anything changes, but even after I played about 20 songs [3 or 4 times listening to the first bits-- then selecting the next song] it was still behaving the same.   I’ve put it in a bag of rice for now & I’m using another one— but does that 44 seconds mean something?

I took the SD card out when I was drying it, and haven’t put it back.

I’ve connected to the computer twice.     Both times, after I disconnected it, it played 49 seconds [not 44] - then returned to the 44 second behavior.

Any thoughts?



After another 24 hours in the ‘rice bag’ - I turned it on and it went past the 44 second mark.    All the way to 57 seconds.   Then it re-started the song, and went to 44 seconds, re-started and repeated.

So it *could* be moisture related, still.   I’ll try again tomorrow.   glad I’ve got a back-up.


Why don’t you try reinstalling the firmware? That might help. Keep in mind that there is a difference between the V1 Fuze and the V2, so you will need to instal the firmware for you device.

Also, do you have copies of your songs, videos, pictures, and whatever else on your computer? If so, then perhaps you could reformat the device and recopy everything. That might help.