Fuze won't accept more than 487 Meg of music

I have a fuze 2 gig and I can’t copy more than 487 Meg to the device from Rhapsody.  I have formated the device twice.  I tried deleting all files via windows.  I deregistered and re-registered the device in Rhapsody, but nothing works.  This has been a great mp3 player and work fine till two days ago.  I wanted to remove all of the songs on it and put new ones on.  So I used Rhapsody to delete all of the tracks on the fuze and that is when I could no longer copy more than 487 meg.


On the Fuze, go to settings > system settings > format > yes.  This will clear the device.

In MTP mode, plug in and sign in to Rhapsody.  Right click on the Fuze and Authorize.

Have a look at the available space at the bottom of the screen within the Rhapsody 4 client.

How much available memory now displays?