fuze will only power on when plugged into computer

I’ve had this sansa fuze since January with no problems. Today it wouldn’t turn on. I tried holding the on/power button numerous times up to 1 1/2 minutes long- nothing. But, when i plug it into the computer it turns on, says connected and shows my battery is fully charged. I unplug it from the computer and it turns off.

Any suggestions? 

(I need my music! I’m packing up a whole house to move-lol!)


ok, i just noticed that when I plugged it into the computer something is wrong with the case.  I can see the light from the display coming out the top and the sides of the player.  The two parts (front and back) are not flush together like they used to be. There is a gap that wasn’t there before.  I don’t understand it. Nothing happened to it, it wasn’t left in the sun- just on my desk- as usual.

If you bought it new, contact SanDisk about a warranty repair or replacement. You have a one-year warranty.

mine does the same thing its wierd but you see… iv had it for 2 years now it in good condition, but it died on me and i lost the charger a month ago, iv just recently found it plug it in says its charging will freeze up after a couple of seconds… or on computer says its conected and its fully charged when i unplug it it turns off. iv tried to reset it, please any help would be very much appretiated, im a student in college it crazy without it. thanks

Sounds like the built-in rechargeable battery isn’t recharging any more. They do wear down. It may just be dead.