fuze+ white screen

My fuze+ went white and it won’t come back. I’ve tried holding the power button several times and it turns off after several seconds but returns white when it powers back up. I tried formatting it through the computer but that didn’t help the white screen problem. I’m stuck.

It might be a hardware problem. Perhaps the screen accidently came unplugged from the motherboard, maybe as a result of bad manufacturing?

Have you tried holding the power button down after it turns off for up to 30 seconds to allow it to reset?

My sansafuze+ screen went blank last night. I’ve tried the suggestions I’ve found on this support site to no avail. This is my SECOND sansafuze+ (the first one lasted nearly 3 years then just STOPPED working [and there wasn’t any useful advice on this site then either]. I even contacted customer support several times and got the same questions and suggestions from what I’ll ASSume was just a bot).

I’m beginning to understand why the i-pod/player products are so popular. My current player is barely 3 months old, so I’ll try to return it to the place of purchase. If that doesn’t work I’ll NEVER purchase from Sandisk again.