Fuze w/ media monkey - "safely remove device" dismounting?

Hey all - used to have an e260 and in Mediamonkey I used to pull down a menu and was given the option to 'safely remove device".  when I hit this the e260 screen would change from “connected” to “disconnected”.  with my new fuze connected I don’t seem to get this option in MM anymore.  Now I just phyisically disconnect the fuze even though the screen says connected.  No ill effects so far.  Any problem with this?

Also, any reason I should install the little CD that came with the fuze?  I play audio only, no DRM stuff, no subscriptions.  Thanks

Chris

@cjcrawford wrote:

Hey all - used to have an e260 and in Mediamonkey I used to pull down a menu and was given the option to 'safely remove device".  when I hit this the e260 screen would change from “connected” to “disconnected”.  with my new fuze connected I don’t seem to get this option in MM anymore.  Now I just phyisically disconnect the fuze even though the screen says connected.  No ill effects so far.  Any problem with this?

 

Also, any reason I should install the little CD that came with the fuze?  I play audio only, no DRM stuff, no subscriptions.  Thanks

 

Chris

The difference might be the USB mode?  The Fuze defaults to MTP, which doesn’t use the “safely remove device” feature.  If you don’t need DRM, you might want to switch to MSC.

IIRC, the CD just has the Sansa Media Converter.  Which is really only needed for video.  And if you decide you want to use it, you should download the latest version anyway.

Thanks - manually switched fuze from 'auto=detect" to MSC, reconnected to MM. Windows saw a new device and installed a driver.  MM still saw the fuze but a: it showed it as being empty, and b: The Sansa icon disppeared from the MM node view and was just replaced by text.  The “safely remove HW” msg was back in MM so I did that and disconnected the device.

Manually switched to MTP mode and reconnected.  The Sansa icon was back on the MM node and the content was visible again.

Another oddity:  before all this began I’m pretty sure the test podcast and audiobook I loaded came up under the “podcast” and “audiobook” folders on the fuze.  After all my switching around the podcast and audiobook folders were empty and the podcast and audiobook content was moved back in the “music” folder.  What are the criteria for the fuze storing podcasts and audiobooks in their respective folders?

Any thoughts on all this.  Thanks very much.

Chris

Weird thing about the Fuze is that anything you put on it in MTP mode does not show up in MSC mode when connected to the computer, and vice versa. Not sure why this is, but if you want all your music to show up on the Fuze, remove everything from the Fuze in MTP mode and reload it in MSC mode. As posted above, MTP is only needed for DRM music.

As for loading podcasts onto the Fuze (I haven’t tried putting audiobooks on it yet), I just use my file manager (in Windoze, it’s called Windows Explorer, but I don’t use Windoze) to put the podcast in the PODCASTS directory. If it’s moving stuff around on you, then there might be something wrong with the tags on the podcasts. I’m not sure how to check the tags on Windoze, but in KDE on Linux, I simply right-click the audio file and click Properties, then go to the META tab. 

Thanks Pikidalto - I’ve played around in with loading in MSC mode and some weird things happen like empty playlists being created on the fuze.  I’ll go back and try again in MSC and create and download some playlists to see what happens.

Chris

@cjcrawford wrote:

Another oddity:  before all this began I’m pretty sure the test podcast and audiobook I loaded came up under the “podcast” and “audiobook” folders on the fuze.  After all my switching around the podcast and audiobook folders were empty and the podcast and audiobook content was moved back in the “music” folder.  What are the criteria for the fuze storing podcasts and audiobooks in their respective folders?

For audiobooks you either need to put the files in the audiobook folder on the Fuze or set the Genre tag to Audiobook.  I think the same is true for podcasts.  By default, the Fuze treats all audio files as music unless the file is in one of the special folders or has a special genre tag.  Also, make sure you have the latest FW as this functionality changed since the initial FW.

@cjcrawford wrote:

Thanks Pikidalto - I’ve played around in with loading in MSC mode and some weird things happen like empty playlists being created on the fuze.  I’ll go back and try again in MSC and create and download some playlists to see what happens.

In MSC mode, the paths in m3u playlists must be relative to the location of the playlist.  MM has a “use relative paths” checkbox somewhere in the syncing options.  Make sure it’s checked.

In other words, if you have a folder structure like:

\MUSIC\<Artist>\<Album>\<Title>.mp3

A playlist in the \MUSIC folder should contain paths that look like:

<Artist>\<Album>\<Title>.mp3

Otherwise the Fuze can’t resolve the path and you get the empty playlist problem.

Message Edited by Skinjob on 12-09-2008 05:14 PM

Message Edited by Skinjob on 12-09-2008 05:14 PM

Thankyou Skinjob - As I may have mentioned, the genre tags are clearly “audiobook” and “podcast”.  MM can sort them as such but when it looks at them on the Fuze, they are all under “music”. - but - when you disconnect the Fuze and then look at the folders, the files have found their way into the correct “podcast” and “audiobbok” folders.  Thanks for the playlist tips, I think I’ll just leave everything in MTP - seems to work better that way.

Chris

@cjcrawford wrote:

Thankyou Skinjob - As I may have mentioned, the genre tags are clearly “audiobook” and “podcast”.  MM can sort them as such but when it looks at them on the Fuze, they are all under “music”. - but - when you disconnect the Fuze and then look at the folders, the files have found their way into the correct “podcast” and “audiobbok” folders.  Thanks for the playlist tips, I think I’ll just leave everything in MTP - seems to work better that way.

 

Chris

Do you have the latest FW?  The original FW handled audiobooks and podcasts differently from the current FW.  IIRC, the behavior you are describing sounds like how the original FW worked.

Also, make sure your tags are ID3v2.3 ISO format.  The Fuze can have trouble with other tag formats.