Fuze v.2 won't turn on

The last few days my Rockboxed Fuze started to act up. Usually several second into selecting a file the display would flicker and then turn white. Otherwise it functioned OK.

So last night I backed up my files and installed Rockbox and formatted the Fuze.

Then I reinstalled Rockbox, since it would not boot up without Rockbox. After I installed Rockbox all looked fine. Display behaved well. Then I reloaded my music files (only) and after they where installed on the internal memory, I unplugged the cable. The screen brought up a white screen with small black writing.

I remember reading something like, Music Panic … Or similar.

So I turned the Fuze off and figured all be well after I reboot my Fuze.

However, nothing happened, totally dead. Computer did not recognize the Fuze and did not turn on the fuze after connecting it.

Looked online for a solution, tried turning the on/off switch to hold for 20 -30 seconds and then to on an hold it for 20 or so seconds. NOTHING

Charged it overnight via USB charger.

Any way I can bring back some live into my Fuze?

It sounds like there are problems with your Rockbox, but…

You can try the force connect method.

With the Fuze off, slide the the power switch down to Hold position.

Connect the USB cord to the computer and open Windows Explorer.

Hold down the  << side of the wheel and connect the Fuze connector while holding it down.  The Fuze should show up in Windows Explorer.

Format it again from the computer–to FAT32 if that’s not the choice that comes up automatically–and try to boot it without Rockbox.

Don’t know if it will do any good.

For what it’s worth, in my brief tryout of Rockbox–I didn’t like it, but it was many versions ago–formatting removed Rockbox as well. I don’t know if that has changed.

You might also look at the forums at www.rockbox.org

Tried it a few times but nothing is happening.

Fuze stays dead and Fuze does not show up in the Explorer.

One possibility is that your cord is breaking. So it’s not charging the Fuze–hence dead when you disconnect–and not making the data connection.

You can get a generic one from Amazon for under $5.  Might be worth a test.

If your Fuze is really old, the battery may also have just come to the end of its rechargeable life. Li-Ion batteries last a very long time but not forever.

And have you tried the Rockbox forums?


Something so simple. Luckily I had a second cable, plugged it up and the Fuze came back t life.