Fuze starts but won't complete FW update

I’ve read through many forum posts but haven’t found an answer on this.

I have a Fuze with 02.01.09 FW, when I try to manually update it (using several different versions of v2 FW), it says it’s updating after diconnecting the cable, but shuts off rather quickly (after about 10 seconds).  It gives no error or msg saying it’s complete.  When I power it back on, the fuzea.bin file is gone from the root directory but the FW version is still the same.

I also tried the updater application.  It correctly shows the current version as 02.01.09, however when it goes to check for a newer version it doesn’t find one, it only finds updates to the video conversion SW.

I’ve tried resetting the device by holding the on button for around 15 seconds, formatting it, and resetting it to factory defaults.  I’ve also tried upgrading to several different versions of FW but they all do the same thing- start the upgrade process and then abruptly shut off the player without completing.

Any ideas on other things to try?

Is the battery above 50%?

The battery is fully charged and holds a charge for several hours when playing music.