Fuze+ says "No Content"

My son’s Fuze+ was powered off for several days (manually turned off, as opposed to having the battery drained). When he turned it back on, every section on the device said, “No Content.” We tried the 20 second reset, both from power-down and power-up, and that didn’t resolve the problem. Any clues?


If you hook it up to a computer, is the content there?

Not yet. Left the cable at his mom’s this weekend. Will see once he returns.

No content on player at all.

Try both USB modes (not Auto Detect). Files will only be visible on your computer if you’re connected in the same mode in which the files were transferrd to the device in the 1st place.

If you are sure nothing’s there, you 'll just have to reload everything. Probably be a good idea to format it first though.

The Fuze+ will display the same songs either on MTP or MSC mode. On other Sansa players, Tapeworm suggestion will apply. I would suggest transferring one song to it and once you unplug it, it should refresh its database. If that does not work, then you would have to format and it reload all your music.

@jamieson wrote:

The Fuze+ will display the same songs either on MTP or MSC mode.

I was referring to seeing the content of the player while connected to the computer. All the players will display what’s on them regardless of transfer mode (provided of course things are working properly and there is content to see).

Are you sure someone didn’t ‘accidentally’ press the Format button and erase everything, and are just not ‘fessing up’ to it?

Im sorry tape I was not clear on that one :smileyvery-happy:. The content of the Fuze+ will show up either on MTP or MSC mode _when connected t_o the computer. Unlike with other Sansa that when you load songs under MTP, those songs will not show up under MSC when you check it on the computer and vice versa. :smiley:

@jamieson wrote:

Im sorry tape I was not clear on that one :smileyvery-happy:. The content of the Fuze+ will show up either on MTP or MSC mode _when connected t_o the computer.


Really? For years SanDisk has said that this phenomenon was due to something in Windows, and beyond their control to alter. With the advent of the Fuze+, did they suddenly find an anti-Microsoft magic potion, or have they been misleading us all this time?



Being able to see “across the fence” involves specifics on the USB controller.  Some other players can allow access to all files regardless of currently selected mode as well.

I too had understood that the limitation is a Microsoft thing, as it actually makes sense given the intricacies of the Plays For Sure platform (MTP), but the new Fuze+ allows access in either mode with the Freescale controller.

The limitations of transfer mode are apparent when using a microSD card.  The device can only be addressed for transferring protected media when it is mounted in the Sansa.  Using a card reader, we can only use MSC mode from the PC, as the licensing platform requires a media device rather than a mass storage device for the transfer.

This limitation is to inhibit (illegal) distribution of media via the cards.  Though having a limitation between modes has obvious advantages in terms of copyright, transferring a protected file (MTP needed) is not possible via MSC, as it cannot be transferred with its license data.  Having the previous “fence” between modes kept the two types separated, but it made for plenty of Sansa users mystified, when their files “disappeared” if the device’s mode changed.

It’s nice to be able to access all media regardless of mode, as long as you remember the differences inherent to each mode.  MTP does quite a few things in the background, as the player automatically adds album folders and art, among other things.  MSC has no automated playlist capability, so you have to use M3U format playlists (path-specific).

No conspiracy involved, the capability difference is in the controller.  The first time I began poking around  with the new platform, it was a surprise to see.

Bob  :smileyvery-happy:

Having this problem now.  My daughter was trying to change her player with a Mac.  It lost the content and would not change.  Will change and load content via Vista.

CHECK YOUR FOLDER STRUCTURE!  I had only had my Fuze+ a couple of days and loaded up a 16GB SD card with music, which was working beautifully.  I followed the recommendation and upgraded the firmware to the latest version and then all I kept getting was - “No content”.  The music was still on the card and I could play it via the PC.  I tried various suggestions - but nothing helped.  Then I realised that I had stored the music in a folder I had created myself, to make it easier to identify different cards.  Although the previous firmware had no trouble reading this, it looks as though the latest firmware will only find the music files if they are either (i) in the root directory or (ii) in the automatically-created “Music” folder.  I simply moved my files into the “Music” folder, and everything is now fine.

you should specify as much details as possible.

i don’t see much info to work with.

such as What operating systems have been connected to the Fuze+

What software was used, for example i either transfer with Winamp or do it manualy

and when i do it manualy i do that in Auto connect mode which is technicaly MTP

on XP x64 and WIn 7 x64 with WMP fully updated.

Also were you using a memory card ? and internal memory ? or both ?

and did the memory card come pre-installed with music on it when you bought ?

I havn’t seen that message unless i removed my content.

So your error seems very weird.

Just like an iPod these things have a database system that cache’s indexed content

but the device is not dependant on it like an iPod. So if you delete the database on an ipod

your never gonna see your files and your screwed. where as on the Fuze+ if you

remove the database it will just recreate it on the next start up etc.

So if its corrupted maybe thats why there is a problem ? although i havn’t seen that happen yet.

And maybe check if anyone dropped it ?

connected it to another machine and ran unknown software etc ?

Did all “sections” have content ? music, books and videos ? or was it music only ?

How old is your son ? any chance he was toying around with options and selected “Format” by accident ?

You need to confirm wether the files are on there or not !

Because if they are gone then you don’t need to mess around with the internal database

and your probably out of luck and just gonna have to start all over again loading content on it etc

A lot of variable come in to play with your problem and tha requires more info if people are going

to be able to help, otherwise your gonna get a wall of speculation etc