Fuze problem with Ubuntu Lucid 10.04

Just upgraded to Ubuntu to 10.04.  My Fuze used connect to an older version of Ubuntu (8.04) but now

it just hangs and I get the following error message.

DBus error org.gtk. Private.RemoveVolume Monitor. Failed:

An operation is already pending.

Beware of the upgrading to 10.04

Similar problem here. I use Linux on my Mac with VirtualBox. Ubuntu 10.04 seems to be different. Before, I could use my Clip + in the AUTO mode. Not anymore. It must be switched to MSC mode. I assume the Fuze is similar. Remember, this is a Clip + forum. Go to System Settings in the Settings panel. Then go to USB Mode. Hope that helps. Fixed my situation. Also, Linux Mint 9 RC is now available. Uses Ubuntu 10.04. Linux Mint 9 plans a final release at the end of this month.

I had the same/similar problem with a Clip+ in Ubuntu  10.04. The problem for me was caused by gvfs-backends or more precisly gphoto (dmesg will give an error message pointing to gphoto). A workaround was to “apt-get remove gvfs-backends”, which makes the Clip+ work, but has some nastly side-effects, as some parts of Gnome depend on gvfs-backends. A better workaround was to just remove anything gphoto related from gvfs-backends via (warning: be careful when playing around with ‘sudo rm’):

sudo rm /usr/share/gvfs/mounts/gphoto2.mount \

 /usr/share/gvfs/remote-volume-monitors/gphoto2.monitor \

 /usr/lib/gvfs/gvfsd-gphoto2 /usr/lib/gvfs/gvfs-gphoto2-volume-monitor

There is a much simpler solution - use the sansa clip settings menu and set usb mode to msc. Then it automounts when you connect it, even on ubuntu 10.04.


Similar here with my Clip+ on 10.04… setting USB mode to MSC though fixed it.

For you Ubuntu users out there… when disconnecting the Clip+ from Ubuntu, do you use “Safely Remove Drive” or “unmount”?