Fuze no longer recognizing pictures in AutoDetect mode after change back from MSC mode/Winamp.

I initially had my Fuze set to “AutoDetect” for USB mode which is how it came. When I connected to my laptop I easily viewed all files in Windows Explorer and moved all my MP3’s to the player using Explorer. Everything was fine. I made a few playlists by right-clicking on selected songs in a directory in Explorer, and they worked fine also. I noticed that they were .pla files so I was a little surprised that the player appeared to be in MTP mode (is this correct?) even though I was using Explorer, not Media Player. Hmm.

After reading some posts on this & other forums I decided to try MSC mode and Winamp. When I did this I found that 1. I didn’t like the Winamp interface and 2. I could no longer right click in Explorer to create playlists. Not good, so I decided to switch back. So I reformatted the Fuze, set it to AutoDetect for USB mode, and tried to copy over my files as I had originally done. The music & playlists came over fine and work well, but the pictures do not show on the Fuze (they DO show up on Explorer when the Fuze is connected). I tried to delete them on the Fuze and copy again from the PC, once in AutoDetect and once in MTP mode on the Fuze, and get the message "You may copy these files and they will be stored but they will not display etc.).

 I know there are many threads that discuss MTP vs. MSC but I did not see this particular issue discussed (sorry if I missed it).

Any help appreciated.

Perhaps the photos are too large? If the resolution of a photo is too high, the Fuze won’t display it. I don’t know where the cutoff is. I made 600x400 copies of my images and dragged and dropped them to the Fuze. They look nice. Others make copies of their images that are exactly the screen size (I don’t remember offhand the exact resolution of the screen).