Fuze has gone "white" after disconnecting from pc

Last night I attempted to sync some music files onto my Fuze using Windows Media Player. I’ve done this many times with no problem.

Because I was in a hurry, I was watching the Windows Media screen to see when my songs had downloaded 100%. As soon as they did, and I saw the message saying “You may now disconnect the Sansa Fuze”, I unplugged the device and took it to my car.

I immediately noticed the screen was glowing white but not displaying any text. I attempted to turn it off, this was not successful. After I got home, I thought maybe it needed more time to finish the sync so plugged it back into the PC. Now it won’t even recognize the device. This morning the screen is still glowing white and I cannot get it to respond at all.

What can I do?



Probably just needs a reset. Slide the power switch up as far as it will go and hold it there for 15 - 30 secs. Release, then see if it starts up normally.

I’ve just had the same issue occur. I’ve tried just about everything imaginable. Holding the power switch up for 30 seconds, pressing and holding the power switch while holding down other buttons, forcing the fuze into MSC mode and trying a  reformat of the drive (which worked, but didn’t fix the problem), loading on new firmware.

When plugged in to my computer the fuze connected and showed up as expected. However, it just shows up as a white screen otherwise. Though I should note that the blue ring surrounding the fuze takes about 3 seconds to respond begin lighting up after a boot despite immediate button presses, indicating potentially that the device is actually loading up and working, but just showing a white screen.

Any help would be appreciated! Thanks!