Fuze freezes in "Play All" mode after playing an Ogg file

Hello,

Silver Sansa Fuze 8 GB, firmware version 01.01.22A, 216 songs only.

From the top menu I select Music --> Play All … and the player *Always* freezes after playing the fourth song (curiously enough “Always” from Bon Jovi). The same happens if I skip the first three songs (pressing >>| ) and let the fourth song play. By freezing I mean that the player becomes unresponsive (regardless of whether the screen is Off or On at the moment) and doesn’t play any more songs. The only way out is to hold the power on slider for a few seconds to force the unit to reset. Also, note that the song plays entirely and well before the freeze occurs.

If I select the same song by any other means, for example going through Music --> Artists --> Bon Jovi --> Play All, or by selecting the song directly from the artist’s Album, the song plays fine and the player doesn’t freeze.

Note that the song “Always,” and all others in the Bon Jovi’s Album, is an Ogg file whereas the three ones before in the “Music -->Play All” mode are mp3. Is there any known bug in the Fuze preventing it to jump form Ogg to mp3 or viceversa while in “PlayAll”? Can any one verify this? Any other ideas?

Thank you.

I want to add that the 5th song in the “Music --> Play All” mode is mp3 again.

@patis wrote:

 

Is there any known bug in the Fuze preventing it to jump form Ogg to mp3 or viceversa while in “PlayAll”? Can any one verify this? Any other ideas?

 

I have heard of this problem before so I installed the mp32ogg package on my Linux box and converted all my mp3’s to OGG format.

This is nevertheless a problem and I will report it to the support team. Hopefully they will schedule it for a fix in a future firmware release.