Fuze freezes at "refresh device" with both 4G and 8G memory cards

I have an 8G fuze, and I use it with audiobooks,  I can’t download books onto either card 4G or 8G from Windows Media Player (I have windows Vista and it’s current) I used the adapter with the card in the computer and it allowed me to transfer onto the 8G card but required it to be formatted (Toshiba) first.  Now when I try to read the books on the card in the Fuze the device freezes at the “refreshing device” screen.  I can only restart the device by removing the cards and rebooting the Fuze.  I have tried switching USB modes and have no success with either-same result.  I should add the before I formatted the cards to the Toshiba prompt I still couldn’t download any books. I suppose it could be bad cards but I purchased them seperately from two different places so that seems a little hard to believe.  Was there a place I should have formatted them to the Fuse device itself?

Fuze doesnt format the cards currently.

I have several utilities at home, but this link to the SD Associationhas a formatting utility for download.

Being able to select and format the µSD card from the device would be a great function!

Bob  :smileyvery-happy: