Fuze constantly frozen

I bought my daughter a fuze for christmas. I charged it, then copied songs to it. It would freeze after playing only one song and not go to the next. No buttons would work. I had to hold power for 20 seconds to reset. Then, sometimes it would play correctly.

Later in the evening, it would freeze trying to choose a song. so, I reset and tried updating the firmware. With new firmware, it will not even start a single song and will completely freeze. After resetting I tried running Chkdsk as suggested in another post, there were no errors found. So I formatted the Fuze(through the fuze settings menu). Then I copied songs back on(all mp3’s with no DRM). Still, it will not play a single song. It freezes needing reset. Did I just buy a lemon, or is this product not really ready for prime time? Firmware is V01.01.22A. 

Also, as a note, when I registered it, I could not select Other… as store, I got it at buy.com and that wasn’t an option. I cannot wait 2 weeks to get this Santa present working.